Main

Behold TV

Общая информация

Возможности программы

Системные требования

Установка WDM драйвера

Описание интерфейса

Ключи командной строки

Советы по видеозаписи

Вопросы и ответы (FAQ)

Контактная информация


Behold TV

Программное обеспечение Behold TV предназначено для работы с телевизионными PC-тюнерами Beholder, построенными на базе 9-ти битных чипсетов Philips SAA7130, Philips SAA7134 и Philips SAA7135.

Основные технические характеристики тюнеров модельного ряда Behold TV приведены в таблицах.

Сравнительная таблица ТВ-тюнеров Behold TV 4-й серии

Модель Behold TV | 401 | 403 | 403FM | 405FM | 407FM | 409FM | Columbus
Интерфейс | PCI 2.1 | PCI 2.1 | PCI 2.1 | PCI 2.1 | PCI 2.1 | PCI 2.1 | PCMCIA Cardbus II
Чипсет | SAA7130HL | SAA7134HL | SAA7134HL | SAA7130HL | SAA7134HL | SAA7135HL | SAA7135HL
Радиомодуль | TCL MK2 | TCL MK2 | TCL MK2 | MK3 | MK3 | MK3 | ALPS TSEZ1
FM-тюнер | – | – | + | + | + | + | TEA5767
Диапазон TV (МГц) | 48.25 – 863.25 | 48.25 – 863.25 | 48.25 – 863.25 | 45.25 – 864.25 | 45.25 – 864.25 | 45.25 – 864.25 | 48.25 – 863.25
Диапазон FM (МГц) | – | – | 66.50 – 168.00 | 65.50 – 158.00 | 65.50 – 158.00 | 65.50 – 158.00 | 68.50 – 128.00
Аудио АЦП | – | 32 кГц | 32 кГц | – | 32 кГц | 32/44.1/48 кГц | 32/44.1/48 кГц
Аудио эффекты | – | – | – | – | – | Регулировка тембра Philips Incredible Mono Philips Incredible Stereo Virtual Surround | Регулировка тембра Philips Incredible Mono Philips Incredible Stereo Virtual Surround
Аудиостандарты FM | – | – | CCIR Stereo | Wide CCIR Stereo | Wide CCIR Stereo | Wide CCIR Stereo | CCIR Stereo
Аудиостандарты TV | BG/DK Mono | BG/DK Mono BG/DK A2 Stereo BG/DK NICAM 728 Stereo | BG/DK Mono BG/DK A2 Stereo BG/DK NICAM 728 Stereo | BG/DK/I/L Mono | BG/DK/I/L Mono BG/DK A2 Stereo BG/DK/I/L NICAM 728 Stereo | Autodetect BG/DK/I/L Mono BG/DK A2 Stereo BG/DK/I/L NICAM 728 Stereo | Autodetect BG/DK/I Mono BG/DK A2 Stereo BG/DK/I NICAM 728 Stereo
Видеостандарты TV (антенный вход) | Autodetect, SECAM (50), PAL (50)
Видеостандарты TV (НЧ входы) | Autodetect, SECAM (50), PAL (50), PAL 60 (60), NTSC M (60), NTSC M Jap (60)
Технологии | –

Сравнительная таблица ТВ-тюнеров Behold TV 5-й серии

Модель Behold TV | 505FM | 505RDS | 507FM | 507RDS | 509FM
Интерфейс | PCI 2.2 | PCI 2.1 | PCI 2.2 | PCI 2.1 | PCI 2.2
Чипсет | SAA7130HL | SAA7130HL | SAA7134HL | SAA7135HL | SAA7135HL
Радиомодуль | MK3/MK5 | MK5 | MK3/MK5 | MK3/MK5 | MK3/MK5
FM-тюнер | + | + | + | + | +
Диапазон TV (МГц) | 45.25 – 864.25 | 45.25 – 864.25 | 45.25 – 864.25 | 45.25 – 864.25 | 45.25 – 864.25
Диапазон FM (МГц) | 65.50 – 158.00 | 65.50 – 158.00 | 65.50 – 158.00 | 65.50 – 158.00 | 65.50 – 158.00
Аудио АЦП | – | – | 32 кГц | 32/44.1/48 кГц | 32/44.1/48 кГц
Аудио эффекты | – | – | – | Регулировка тембра Philips Incredible Mono Philips Incredible Stereo Virtual Surround | Регулировка тембра Philips Incredible Mono Philips Incredible Stereo Virtual Surround
Аудиостандарты FM | Wide CCIR Stereo | Wide CCIR Stereo RDS | Wide CCIR Stereo | Wide CCIR Stereo RDS | Wide CCIR Stereo
Аудиостандарты TV | BG/DK/I/L Mono | BG/DK/I/L Mono | BG/DK/I/L Mono BG/DK A2 Stereo BG/DK/I/L NICAM 728 Stereo | Autodetect BG/DK/I/L Mono BG/DK A2 Stereo BG/DK/I/L NICAM 728 Stereo | Autodetect BG/DK/I/L Mono BG/DK A2 Stereo BG/DK/I/L NICAM 728 Stereo
Видеостандарты TV (антенный вход) | Autodetect, SECAM (50), PAL (50)
Видеостандарты TV (НЧ входы) | Autodetect, SECAM (50), PAL (50), PAL 60 (60), NTSC M (60), NTSC M Jap (60)
Технологии | Internal IR

Сравнительная таблица ТВ-тюнеров Behold TV 6-й серии

Модель Behold TV | 607FM | 607RDS | 609FM | 609RDS | M6 | M6 Extra
Интерфейс | PCI 2.2 | PCI 2.2 | PCI 2.2 | PCI 2.2 | PCI 2.2 | PCI 2.2
Чипсет | SAA7134HL | SAA7134HL | SAA7135HL | SAA7135HL | SAA7135HL | SAA7135HL
Радиомодуль | MK3/MK5 | MK3/MK5 | MK3/MK5 | MK3/MK5 | MK3/MK5 | MK3/MK5
FM-тюнер | + | + | + | + | + | +
Диапазон TV (МГц) | 45.25 – 864.25 | 45.25 – 864.25 | 45.25 – 864.25 | 45.25 – 864.25 | 45.25 – 864.25 | 45.25 – 864.25
Диапазон FM (МГц) | 65.50 – 158.00 | 65.50 – 158.00 | 65.50 – 158.00 | 65.50 – 158.00 | 65.50 – 158.00 | 65.50 – 158.00
Аудио АЦП | 32 кГц | 32 кГц | 32/44.1/48 кГц | 32/44.1/48 кГц | 32/44.1/48 кГц | 32/44.1/48 кГц
Аудио эффекты | – | – | Регулировка тембра Philips Incredible Mono Philips Incredible Stereo Virtual Surround | Регулировка тембра Philips Incredible Mono Philips Incredible Stereo Virtual Surround | Регулировка тембра Philips Incredible Mono Philips Incredible Stereo Virtual Surround | Регулировка тембра Philips Incredible Mono Philips Incredible Stereo Virtual Surround
Аудиостандарты FM | Wide CCIR Stereo | Wide CCIR Stereo RDS | Wide CCIR Stereo | Wide CCIR Stereo RDS | Wide CCIR Stereo | Wide CCIR Stereo RDS
Аудиостандарты TV | BG/DK/I/L Mono BG/DK A2 Stereo BG/DK/I/L NICAM 728 Stereo | BG/DK/I/L Mono BG/DK A2 Stereo BG/DK/I/L NICAM 728 Stereo | Autodetect BG/DK/I/L Mono BG/DK A2 Stereo BG/DK/I/L NICAM 728 Stereo | Autodetect BG/DK/I/L Mono BG/DK A2 Stereo BG/DK/I/L NICAM 728 Stereo | Autodetect BG/DK/I/L Mono BG/DK A2 Stereo BG/DK/I/L NICAM 728 Stereo | Autodetect BG/DK/I/L Mono BG/DK A2 Stereo BG/DK/I/L NICAM 728 Stereo
Видеостандарты TV (антенный вход) | Autodetect, SECAM (50), PAL (50)
Видеостандарты TV (НЧ входы) | Autodetect, SECAM (50), PAL (50), PAL 60 (60), NTSC M (60), NTSC M Jap (60)
Аппаратное кодирование видео | - | - | - | - | MPEG2 | MPEG2
Аппаратное кодирование аудио | - | - | - | - | LPCM, MPEG1 Layer-2 | LPCM, MPEG1 Layer-2, AC-3
Технологии | ADSS, ARPC, Internal IR


Base features

Ключевые возможности Behold TV

  • Просмотр телевизионных программ, работающих в диапазоне 45.25 - 864.25 МГц (см. таблицу моделей).
  • Прослушивание УКВ/FM радиостанций в стандартном и расширенном (65.5-168 МГц) диапазоне (см. таблицу моделей).
  • Прием и декодирование RDS потока, с последующим выводом RDS данных в FM режиме (только для моделей тюнеров с декодером RDS, см. таблицу моделей).
  • Гибкие методы настройки ТВ и FM радио программ.
  • Поддержка профилирования ТВ и FM каналов для использования тюнера в разных территориальных зонах приема.
  • Приём телевизионных программ со звуковым форматом A2/NICAM Stereo (только для моделей тюнеров на чипсете SAA7134/35).
  • Тонкая настройка параметров декодера A2/NICAM (только для моделей тюнеров на чипсете SAA7134).
  • Быстрое аппаратное автоопределение системы звука - BG/DK/I/L и формата кодирования звука - Mono/A2/NICAM (только для моделей тюнеров на чипсете SAA7135).
  • Индивидуальные настройки тембра низких и высоких частот звука для каждого канала, а также для каждого НЧ входа (только для моделей тюнеров на чипсете SAA7135).
  • Индивидуальные настройки виртуальных звуковых эффектов - Philips Incredible и Virtual Dolby Surround для каждого канала, а также для каждого НЧ входа (только для моделей тюнеров на чипсете SAA7135).
  • Индивидуальные настройки яркости, контрастности, оттенка (только PAL), насыщенности, четкости, уровня входного сигнала (Gain), аудиоформата (BG/DK/I/L, Mono, A2, NICAM), видеоформата (Авто/PAL/SECAM), громкости, аудио баланса левого и правого канала, значения зума и позиции кадра для каждого ТВ канала.
  • Индивидуальные настройки видеоформата (Авто/PAL/SECAM/NTSC/PAL60), яркости, контрастности, оттенка (только PAL/NTSC), насыщенности, четкости, уровня входного сигнала (Gain), а также режима синхронизации строк для каждого НЧ входа.
  • Встроенное OSD меню.
  • Настройка стиля отображения OSD.
  • Работа с пультом дистанционного управления и гибкая настройка кнопок ПДУ под заданные действия.
  • Одновременная поддержка нескольких сторонних ПДУ стандарта NEC и их гибкая конфигурация (только для моделей тюнеров с технологией ARPC, см. таблицу моделей).
  • Включение компьютера с пультов ДУ (только для моделей тюнеров с технологией ARPC, см. таблицу моделей).
  • Включение компьютера по внутреннему таймеру (только для моделей тюнеров с технологией ARPC, см. таблицу моделей).
  • Гибкая настройка горячих клавиш для управления приложением.
  • Поддержка баз ТВ программы телепередач формата JTV с отображением информации в OSD.
  • Многоязыковый интерфейс - Русский, Английский.
  • Использование "Агента" для запуска программы с пульта ДУ.
  • Использование "Агента" для запуска заданий встроенного планировщика.
  • Использование "Агента" для автоматической закачки и обновления баз ТВ Программ.
  • Изменение размера кадра выводимого видеопотока (до 768x576) при просмотре.
  • Изменение режима соотношения сторон кадра - 4:3, 16:9 PanScan, 16:9 Anamorphic.
  • Поддержка технологии вывода видео VMR - Video Mixing Renderer (только для Windows XP, Windows 2003).
  • Вывод видеоизображения в полупрозрачном режиме окна.
  • Вывод видеоизображения в качестве обоев рабочего стола Windows.
  • Использование видеообработки изображения на основе подключаемых плагинов, что дает возможность расширения системы.
  • В дистрибутив входят несколько плагинов деинтерлейсинга (удаление эффекта расчески), плагин для удаления высокочастотного шума, а также плагин для улучшения резкости изображения.
  • Использование программной функции Smart Interleave, позволяющей удвоить частоту кадров при просмотре в два раза (25->50 fps).
  • Использование аппаратных функций видеокарт - деинтерлейсинга и механизма удвоения частоты кадров.
  • Вывод оцифрованного звука по шине PCI на прослушивание, с автоматической синхронизацией АЦП чипсета Philips и ЦАП звуковой платы (только для чипсетов Philips SAA7134 и SAA7135), без использования аналогового аудио кабеля, соединяющего выход тюнера со входом звуковой платы.
  • Оцифровка и вывод звука по шине PCI при прослушивании в режиме Dolby Pro Logic с разложением в 4-x канальный Surround по 3 возможным схемам - Surround, Phantom Center, X3 Stereo (только для чипсета Philips SAA7135).
  • Многоканальный предварительный просмотр каналов (Серфинг).
  • Режим Таймшифт (отложенный просмотр) для видео/аудио и отдельно для аудио. Для моделей с аппаратным энкодером MPEG, режим Таймшифт исполняется аппаратно со стороны сжатия и записи потока.
  • Просмотр, отложенный просмотр (Таймшифт) и запись программ по расписанию с использованием встроенного интеллектуального планировщика.
  • Восстановление системы из режима Hibernate/Suspend при подходе задания планировщика (необходим загруженный Агент Behold TV, либо ПО Behold TV).
  • Установка таймера на выключение, либо на уход в режим Hibernate/Suspend.
  • Захват отдельных кадров в формате BMP и JPEG как вручную, так и по таймеру.
  • Запись звука в WAV формате с применением ACM кодеков по технологии Microsoft ACM и DirectShow.
  • Запись звука в MPEG1 Layer-2 (с установленным энкодером InterVideo MPEG). Запись возможна с разбиением файла на сегменты заданного размера.
  • Запись звука в Microsoft WMA формате, а также в любом доступном формате в составе контейнера Microsoft ASF (требуется Windows XP SP2 и выше, либо установленное обновление Microsoft Windows Media Format Runtime). Запись возможна с разбиением файла на сегменты заданного размера.
  • Запись звука в формате MPEG1 Layer-2, AC-3 через аппаратный MPEG энкодер (только для моделей тюнеров с аппаратным энкодером, см. таблицу моделей). Запись возможна с разбиением файла на сегменты заданного размера.
  • Вещание звука в IP-сеть в формате Microsoft WMA, а также в любом доступном формате в составе контейнера ASF (требуется Windows XP SP2 и выше, либо установленное обновление Microsoft Windows Media Format Runtime).
  • Запись видео/аудио в формате Microsoft AVI (размером кадра до 768x576) с использованием доступных VCM и DirectShow видео кодеков и ACM аудио кодеков с отображением подробной информации о процессе записи.
  • Запись видео/аудио в формате MPEG1 и MPEG2 (с установленным энкодером InterVideo MPEG). Запись возможна с разбиением файла на сегменты заданного размера.
  • Запись видео/аудио в Microsoft WMV формате, а также в любом доступном формате в составе контейнера ASF (требуется Windows XP SP2 и выше, либо установленное обновление Microsoft Windows Media Format Runtime). Запись возможна с разбиением файла на сегменты заданного размера.
  • Запись видео в формате MPEG2 (ISO/IEC13818-2) со звуковым потоком в формате LPCM, MPEG1 Layer-2 (ISO/IEC13818-3), AC-3 через аппаратный MPEG энкодер, с гибким конфигурированием параметров энкодера (только для моделей тюнеров с аппаратным энкодером, см. таблицу моделей). Запись возможна с разбиением файла на сегменты заданного размера.
  • Вещание видео/аудио в IP-сеть в формате Microsoft WMV а также в любом доступном формате в составе контейнера ASF (требуется Windows XP SP2 и выше, либо установленное обновление Microsoft Windows Media Format Runtime).
  • Вещание MPEG потока в IP сеть по протоколу UDP Multicast.
  • Подрезка (cropping) краев кадра при записи видео (только для программной записи).
  • Масштабирование кадра при записи видео (только для программной записи).
  • Использование видеообработки изображения на основе плагинов при записи видео (только для программной записи).
  • Одновременная запись и просмотр записываемого видео.
  • Запись оцифрованного звука с использованием внутреннего АЦП чипсета Philips SAA7134 (32кГц) и Philips SAA7135 (32/44.1/48кГц) по шине PCI.
  • Сохранение настроек для записи видео, аудио, а также скриншота в загружаемых пресетах.
  • Быстрый выбор лимита времени записи, нажатием одной клавиши или кнопки ПДУ.
  • Русифицированный телетекст (требуется DirectX 8.1 и выше).

Примечания:

  • ARPC - Advanced Remote & Power Control
    ARPC позволяет тюнеру:
    - Работать с другими пультами ДУ, работающими в стандарте NEC.
    - Включать компьютер по внутреннему таймеру.
    - Включать компьютер с пульта ДУ.
    - Включать компьютер через шину PCI при наличии поддержки PME со стороны материнской платы.
    - Включать компьютер, эмулируя нажатие кнопки питания для тех систем, которые не имеют поддержку PME.
    - Обновлять микропрограммный код блока ARPC.
  • ADSS - Analog/Digital Separate Shielding. Означает сплошное и раздельное экранирование цифровой и аналоговой части, что увеличивает помехоустойчивость тюнера и уменьшает собственный уровень паразитных шумов


System Requirements

Системные требования

Программные требования

  • Операционная система Windows 98SE/ME, Windows 2000/XP/2003, Windows XP Professional x64 Edition, Windows 2003 Server x64 Edition, Windows Vista x86/x64 (Windows XP SP2 рекомендуется).
  • Минимальное разрешение рабочего стола Windows - 800x600, 16 бит.
  • Установленный DirectX 8.1 или выше (DirectX 9.0c рекомендуется).
  • Установленный универсальный WDM драйвер Behold TV версии 4.3.5.0 и выше.
  • Обязательная установка пакета драйверов для материнских плат от производителя (например для VIA - пакет 4in1).

Аппаратные требования

  • Процессор Intel Pentium II 450 и выше, Intel Pentium III/4, AMD Duron/Sempron/Athlon XP/Athlon64 рекомендуется. Для использования всех функций видеопроцессинга требуется процессор не менее PIII-1000. Для захвата полного кадра 720x576 со сжатием MPEG2, DivX, WMV требуется процессор не ниже AMD Athlon XP 2500+ или Intel P4 2400.
  • 64 МБ оперативной памяти (для видеозахвата необходимо иметь минимум 128 МБ). Рекомендуемый объем 256 МБ.
  • DirectSound и DirectShow – совместимая звуковая плата.
  • DirectDraw – совместимый AGP или PCI-Express видеоадаптер с поддержкой оверлея в формате YUY2.
  • Жесткий диск на 5400 об/мин. Для захвата видео желательно иметь диск на 7200 об/мин или RAID массив.


WDM Driver

Установка WDM драйвера

Для работы программы Behold TV, а также сторонних прикладных приложений требуется установленный WDM драйвер для ТВ тюнера.

Компания Beholder поставляет для всей линейки ТВ тюнеров, основанных на PCI чипсетах Philips SAA7130/7134/7135 высококачественный унифицированный WDM драйвер для операционных систем Microsoft Windows 98SE/ME/2000/XP/2003/Vista, включающий в себя поддержку двух платформ - x86 и AMD64. Данный драйвер базируется на новой технологии Microsoft AVStream и скомпилирован с помощью новейшего Microsoft WDK 6000. Для установки драйвера обязательно требуется наличие установленного Microsoft DirectX 9 или выше. Операционные системы Windows XP SP2/XP MCE2005 поставляются уже с предустановленным DirectX 9.0c. Windows Vista поставляется изначально с DirectX 10.

Для установки WDM драйвера достаточно запустить файл Install.exe из папки WDM драйвера. Установка драйвера допустима только при наличии прав Администратора (кроме Windows 98SE/ME).

Перед установкой настоятельно рекомендуется выбрать пункт "Deinstall Behold TV WDM driver". Если данный пункт недоступен (драйвер еще не был установлен), то достаточно перейти к установке. Под операционными системами Windows XP MCE2005, а также Windows Vista будет выполнена проверка запущенного сервиса Media Center Receiver (ehRecvr) и автоматическая его остановка. Данное действие необходимо для освобождения компонент драйвера ТВ тюнеров Behold TV M6/Extra от сервиса ehRecvr, который захватывает устройство энкодера и устройство видеозахвата.

После выполнения деинсталляции, необходимо выбрать первый пункт "Install (Reinstall) Behold TV WDM driver" и нажать кнопку Run. При этом под Windows 98SE/ME будет выполнена первая часть установки, затем программа инсталляции попросит перезагрузить Windows. После перезагрузки Windows 98SE/ME будет автоматически выполнена вторая часть установки, после чего WDM драйвер будет установлен и готов к работе.

Под Windows 2000/XP/2003/Vista драйвер установится без перезагрузки системы. Если из иконки в трее появится баллонное сообщение типа:

то его нужно проигнорировать, так как данное сообщение вызвано закрытием "Мастера Установки Нового Оборудования", которого принудительно закрыла утилита установки, после чего Мастер выдал данное сообщение. Утилита установки Install.exe не нуждается в "Мастер Установки Нового Оборудования" и всю работу по установке выполняет сама.

После успешной установки драйвера, в Диспетчере устройств появится новое устройство Behold TV, одно на каждую PCI карту Beholder:

Возможные проблемы с установкой драйвера

Windows 2000

При установке под Windows 2000 может появиться сообщение о том, что требуются некоторые файлы и Windows попросит установочный диск Windows 2000, после чего подменит некоторые компоненты системы старыми файлами (без сервис паков). Чтобы этого не произошло, необходимо убедиться, что в папке \WinNT\Driver Cache\i386 лежал файл driver.cab а также sp#.cab (где # - версия сервис пака, например sp3.cab).

Windows XP Home Edition

Перед установкой драйвера требуется кликнуть правой кнопкой мыши по значку "Мой компьютер" и в контекстном меню выбрать "Свойства". На закладке "Оборудование" нажать кнопку "Подписывание драйверов" и выбрать пункт "Пропускать" или "Предупреждать".


Interface

Интерфейс программы

Видеоокно

Главная панель

Панель настроек

Панель записи

Планировщик

Агент


Main Screen

Behold TV - Видеоокно

Правый клик мыши в области видеоокна вызывает контекстное меню:

  • На полный экран - Переключение в полноэкранный/оконный режим.
  • Видео на рабочий стол - Установить видео как обои рабочего стола Windows. Недоступно в Windows Vista при активной Aero. Для возврата в оконный режим необходимо выбрать команду "Восстановить видео" в контекстном меню иконки в трее, либо в контекстном меню кнопки ПО на панели задач.
  • Прозрачное окно - Переключить окно в полупрозрачный режим. Доступно только в режиме вывода видео как "Первичная поверхность".
  • Простое меню/Расширенное меню - Переход в режимы сокращенного/полного меню.
  • Таймшифт - Запустить Таймшифт - функцию отложенного просмотра.
  • Каналы - Список настроенных ТВ каналов для быстрого доступа.
  • ТВ Программа - Вызов меню настройки ТВ программ.
  • Серфинг каналов - Серфинг (предпросмотр) каналов в мозаике.
  • Соотношения сторон - Соотношения сторон кадра.
  • Размер видеоокна - Геометрический размер видеоокна.
  • Размер видеопотока - Размер кадра для видеопотока.
  • Видеообработка - Вызвать диалог настройки видеообработки, либо вызвать диалог настройки любого подключенного плагина.
  • Видеовход - Переключение входов TV, VHS (CVBS), S-VHS (SVideo).
  • Видеостандарт - Выбор видео стандарта Авто/PAL/SECAM/NTSC.
  • Синхронизация кадров - Режим восстановления вертикальной синхронизации при декодировании видеосигнала (cм. описание).
  • Аудиостандарт - Выбор аудио стандарта (доступно только для тюнеров на чипсете SAA7134/35).
  • Аудиоканал - Выбор аудиоканала звукового сопровождения. В ТВ режиме каналы Stereo, Language1 и Language2 работают только при наличии ТВ стереовещания A2/NICAM/BTSC/EIAJ на текущем канале. Канал BTSC SAP доступен только для BTSC стандарта и только для тюнеров на чипсете SAA7135. В режиме НЧ входов выбирается режим линии аудио входа.
  • WST телетекст - Включает/выключает режим просмотра телетекста.
  • Настройки - Вызов окна настроек.
  • Видеозахват - Открыть панель записи.
  • Планировщик - Вызов окна конфигурирования планировщика задач.
  • Окно с бордюром - Отображать видеоокно с бордюром.
  • Окно поверх всех окон - Располагать видеоокно (независимо от главной панели) поверх всех других окон.
  • Скрыть видеоокно - Спрятать видеоокно.
  • Убрать в трей - Перевести программу в режим ожидания.
  • Выход - Выйти из программы.

Примечание:
PCMCIA ТВ тюнер Behold TV Columbus имеет дополнительную строку меню "Извлечь тюнер", при выполнении которой произойдет выход из ПО и деинициализация WDM драйвера, для того чтобы быстро и безопасно извлечь PCMCIA карту из слота.


Main Panel

Behold TV - Главная панель

Свернутая

Развернутая

Свернутая, в режиме работы "Таймшифт"

Свернутая, в режиме FM, декодирование RDS

  • FM - Переключиться в режим "FM тюнер" (только для модели с FM).
  • VHS - Переключиться в режим "Вход CVBS".
  • S-VHS - Переключиться в режим "Вход S-Video".
  • TV - Переключиться в режим "TV тюнер".
  • TEXT - Включить/выключить телетекст.

Использование режима Таймшифт

По аналогии с паузой при просмотре/прослушивании обычной видео- или аудиозаписи, "Таймшифт" запускается аналогичной кнопкой "Pause" [image] на основной панели управления приложением. На активирование режима "Таймшифт" требуется несколько секунд, по истечении которых становятся доступны кнопки "Play" [image] и "Stop" [image], с помощью которых можно запустить отложенный на время "Смещение" просмотр или, соответственно, выйти из режима "Таймшифт". Если в процессе воспроизведения требуется снова на какое-то время приостановить просмотр или прослушивание текущей программы, то это всегда можно сделать, повторно нажав кнопку "Pause". В режиме "Таймшифт" вы всегда можете перейти к просмотру/прослушиванию любого фрагмента передачи, начиная с момента запуска "Таймшифт" и заканчивая текущим временем. Выбор произвольного фрагмента осуществляется с помощью горизонтального слайдера, либо кнопками [image] [image] , позволяющими перемещаться по временной шкале с заданным шагом назад и вперед соответственно. При перемещении слайдера мышью будет отображаться справочная информация о:

  1. Текущей позиции относительно начала работы функции "Таймшифт".
  2. Общей длительности работы функции "Таймшифт".
  3. Рассчетного остаточного времени работы функции "Таймшифт" (на основании свободного места на диске).

При перемещении слайдера с помощью мыши, текущая позиция воспроизведения устанавливается только после того, как кнопка мыши будет отпущена. В процессе работы функции "Таймшифт" будет недоступно переключение каналов, а также будут заблокированы многие функции и некоторые окна программы.

Использование режима Телетекст

Телетекст представляет собой текстовую информацию, передаваемую в составе телевизионного сигнала в невидимых служебных (VBI) строках каждого кадра. Данная информация может быть выделена из телевизионного сигнала, декодирована и выведена на экран в виде страниц и подстраниц телетекста.
Режим телетекста в программе Behold TV включается/выключается нажатием кнопки "TEXT" на панели управления программой, выбором соответствующей строки в контекстном меню видеоокна или нажатием заданной в настройках комбинации клавиш на клавиатуре или пульте ДУ.
Если данные телетекста присутствуют в телевизионном сигнале (выбранный канал транслирует телетекст), то при включении режима телетекста в левом верхнем углу экрана на чёрном или прозрачном фоне появится номер текущей выбранной страницы и счётчик декодируемых в настоящий момент страниц. Выбранная страница будет отображена на экране сразу, как только информация о ней будет передана в составе телевизионного сигнала и декодирована программным WST (World System Teletext) декодером.
Если при включении режима телетекста счётчик декодируемых страниц не появится и экран будет оставаться пустым, значит с большой долей вероятности выбранный канал телетекст не транслирует.
При активном режиме телетекста, переключение номера страниц производиться клавишами переключения каналов. Также, требуемый номер страницы можно набрать с помощью цифровых клавиш, либо с кнопок ПДУ. Некоторые страницы телетекста имеют вложенные подстраницы. Количество подстраниц отображается в верхней служебной строке. WST декодер автоматически меняет подстраницы через определенный промежуток времени. Нужную подстраницу можно выбрать вручную клавишами "PageUp" и "PageDown". Правый клик мыши по кнопке "TEXT" дает возможность настроить параметры работы функции Телетекст. Таким образом можно выбрать режим прозрачного фона (наложение страницы на видео), активировать скрытый текст на страницах телетекста, а также включить режим удержания страницы, при котором WST декодер не будет автоматически листать подстраницы на текущей странице телетекста.
WST декодер входит в состав DirectShow и качество его работы полностью зависит от установленной версии пакета Microsoft DirectX. В некоторых случаях, на каналах с неуверенным приемом, WST декодер будет испытывать проблемы с декодированием страниц, что выражается в большой задержке появления страниц, либо появлению ошибок на страницах. В подобной ситуации может помочь подстройка частоты ТВ канала на +/- 0.5MHz. Также, любые искажения, вносимые, например, многолучевым приёмом антенны (малейшие двоения и троения изображения на экране), могут сделать декодирование телетекста полностью невозможным.

Декодирование RDS

Декодирование RDS потока доступно только для моделей с поддержкой RDS (см. таблицу моделей). Процесс декодирования RDS работает автоматически в режиме FM тюнера и его работа зависит от сигнала передающей радиостанции. Если радиостанция не имеет поддержки RDS, то на LCD экране значок RDS будет неактивен. При обнаружении RDS потока, загорается индикатор RDS и через 1-2 секунды появляется Program Service Name - наименование радиостанции, которое закодировала сама передающая радиостанция. Если передающая радиостанция указывает в RDS потоке код страны/региона вещания, он будет отображен на LCD экране. Также, радиостанции могут передавать в потоке RDS текст, в котором обычно находится название текущей композиции, а также всякого рода полезная информация.

Примечания

  • Правый клик мыши по кнопке "CH" вызывает контекстное меню со списком настроенных TV или FM каналов.
  • Правый клик мыши по первой строке LCD панели вызывает контекстное меню со списком настроенных TV или FM каналов.
  • Двойной клик мыши по первой строке LCD панели вызывает окно ТВ Программы (только в режиме TV).
  • Правый клик мыши по второй строке LCD панели вызывает контекстное меню с режимами скроллинга текста.
  • Клик мыши по LCD ячейке часов выводит в этой ячейке информацию об оставшемся времени до срабатывания таймера на выключение.
  • Правый клик мыши по LCD ячейке часов вызывает контекстное меню таймера на выключение.
  • Правый клик мыши по кнопкам Фотоаппарата, Микрофона и Видеокамеры вызывает контекстное меню с возможностью быстрой загрузки пресетов с готовыми настройками записи Снимков, Аудио и Видео соответственно.
  • Правый клик мыши по кнопке Фотоаппарата дает возможность выбора режима работы скриншота - "Снимок" или "Серия снимков".
  • Правый клик мыши по кнопкам перемотки "Таймшифт" [image] [image] вызывает контекстное меню с возможностью настройки шага перемотки. Шаг настраивается раздельно для перемотки назад и перемотки вперед.
  • Кнопки "Stop", Pause", "Play" имеют разные функции в зависимости от текущего режима работы. Данные кнопки предназначены для режима Таймшифт, также они функционируют в режимах записи/воспроизведения. В зависимости от текущего режима работы, эти кнопки будут иметь различные всплывающие подсказки.


OptionsPanel

Behold TV - Панель настроек

1. Закладка по настройке ТВ каналов:

  • Основные параметры TV канала - Ввод наименования и частоты, установка видео и аудио стандарта для выбранного телевизионного канала.
    • Порог АРУ - Для ТВ тюнеров, имеющих ВЧ блок MK3/MK5, доступна настройка порога срабатывания АРУ. Порог АРУ помогает подстроить каналы с повышенным уровнем радиосигнала и устранить такие дефекты, как рябь и плывущие широкие белесые горизонтальные полосы.
    • Видео стандарт - Настройка видеостандарта для выбранного канала. По умолчанию установлен Autodetect (Автоопределение). Можно принудительно вручную установить желаемый стандарт (PAL/SECAM). Ниже, в информационной рамке отображается реально декодируемый стандарт на текущий момент.
    • Аудио стандарт - Настройка аудиостандарта для выбранного канала. Доступна только для ТВ тюнеров, построенных на чипсете SAA7134/35. Для ТВ тюнера на чипсете SAA7134 также доступна кнопка для точной ручной подстройки несущих звука. В России и СНГ используется стандарт ТВ звука D/K. Некоторые каналы могут транслировать стереозвук в цифровом стандарте NICAM 728. Выберите стандарт D/K NICAM, и если чипсет SAA7134 обнаружит в транслируемом сигнале цифровой NICAM, то включится его декодирование и в статусе загорится "NICAM Stereo". Стандарт A2 (DualFM) представляет собой аналоговый стандарт передачи стереозвука (на подобии FM), который используется в основном в странах Европы, а также в системах кабельного ТВ. Для чипсета SAA7135 достаточно выбрать стандарт BG/DK auto и чипсет сделает полный автодетект системы звука BG/DK и формата кодирования - Mono/A2/NICAM. В информационной рамке отображается стандарт, определенный и декодированный чипсетом.
    • Синхронизация строк - Подстройка горизонтальной синхронизации (HPLL) видео декодера SAA713x для выбранного канала. Для большинства каналов рекомендуется режим Fast track. Однако для некоторых каналов с плохим качеством изображения может потребоваться установка режима Poor signal. Режим VCR предназначен для синхронизации сигнала, подаваемого с VHS ленты видеомагнитофона.
  • Громкость - Громкость и баланс линейного входа для выбранного канала. Данные настройки могут быть недоступны, если на закладке Аудио установлен "Режим управления громкостью" как "Общая громкость для всех каналов".
  • Тембр - Подстройка тембра ВЧ и НЧ для выбранного канала. Доступно только для чипсета SAA7135.
  • Звуковой эффект - Установка виртуального звукового эффекта для выбранного канала. Доступно только для чипсета SAA7135.
  • Видеомикшер - Группа элементов для изменения яркости, контрастности, оттенка (только для PAL), насыщенности, резкости и видеоусиления (Gain) для выбранного канала. Рядом расположена кнопка установки всех регуляторов видеомикшера в значение по умолчанию и кнопки, применяющие каждые регулировки ко всему списку каналов. Регулятор "Видеоусиление (Gain)" доступен только в режиме ручной регулировки видеоусиления. В противном случае работает видео АРУ (AGC - Automatical Gain Control). Дополнительные параметры для подстройки видео АРУ можно найти на закладке Видео.
  • Автосканирование - Вызывает окно диалога для поиска ТВ каналов.

Флажок напротив каждого канала позволяет разрешать или пропускать канал при перелистывании каналов.
Кнопки [image] , [image] и [image] позволяют добавить, вставить и удалить выбранный канал из списка каналов. Для создания, выбора, удаления профиля каналов, необходимо кликнуть по кнопке [image] и выполнить требуемое действие.

Примечаниe: При первом запуске программа по умолчанию предлагает список TV-каналов, транслируемых с Останкино и которые можно принимать в Москве и Московской области на индивидуальную телевизионную антенну. Если вы пользуетесь услугами кабельного провайдера или проживаете в другом регионе, то список телевизионных каналов (Moscow), скорее всего, необходимо будет перенастроить, либо создать профиль каналов для своего города. Список каналов по умолчанию в программе может периодически меняться и дополняться.

1.1. Окно автосканирования ТВ каналов:

Автосканирование ТВ каналов можно осуществить двумя способами - просканировать заранее определенную для каждого региона сетку ТВ частот (быстрое сканирование), либо отсканировать весь диапазон ТВ частот с шагом 0.25 MHz (медленное сканирование). Недостаток первого способа заключается в том, что в ряде регионов транслирование некоторых каналов может вестись в соответствии с нестандартной сеткой частот, что не позволит вам найти такие каналы при автопоиске. Второй режим позволяет найти все каналы без исключения, транслируемые в данной местности (в зоне удовлетворительного приема).

  • Видеостандарт по умолчанию - Задает видеостандарт, устанавливаемый для каждого найденного канала при добавлении его в список.
  • Аудиостандарт по умолчанию - Задает аудиостандарт, устанавливаемый для каждого найденного канала при добавлении его в список.
  • Очищать список каналов - Очистить список перед добавлением найденных каналов.
  • Добавлять только новые - Выполнять "сквозное" автосканирование. В список будут добавлены только новые обнаруженные каналы (при автоматическом или полуавтоматическом сканировании).
  • Выбор режима сканирования - Определить диапазон и шаг сканирования:
    • По списку эфирных каналов - Выбрать предустановленную сетку эфирных каналов для данного региона (быстрое сканирование).
    • По списку кабельных каналов - Выбрать предустановленную сетку кабельных каналов для данного региона (быстрое сканирование).
    • По всему списку каналов - Выбрать предустановленную сетку эфирных + кабельных каналов для данного региона (быстрое сканирование).
    • По частоте (весь диапазон) - Выбрать полный диапазон ТВ частот с шагом 0.25 Mhz (медленное сканирование). Позволяет найти ВСЕ каналы, которые транслируются в данной местности, часть которых может транслироваться на нестандартных частотах и не попадать в стандартные сетки региона.
  • Выбор региона - Выбрать регион, для которой определена сетка ТВ частот. Доступно только для режимов сканирования "По списку антенных каналов", "По списку кабельных каналов" и "По всему списку каналов".
  • Наличие видеосигнала и Наличие несущей - Датчики, показывающие текущий статус радиоблока. Найденной считается та ТВ частота, на которой оба датчика активны.
  • Автоскан - Запуск выбранного режима сканирования по полному диапазону от начала до конца с занесением найденных каналов в список (автоматическое сканирование).
  • Стрелки << и >> - Запуск выбранного режима сканирования с текущего места диапазона в прямом или обратном направлении (полуавтоматическое сканирование). Если установлена галочка "Автосохранение", то при обнаружении канала он будет добавлен в список и сканирование будет продолжено дальше. Если галочка "Автосохранение" снята, то при обнаружении канала поиск остановится, предоставив пользователю выбор - добавить канал в список через кнопку "Добавить" и/или продолжить сканирование.
  • Стрелки < и > - Ручное изменение частоты на один шаг в прямом или обратном направлении.

1.2. Окно настройки ТВ Программы:

ТВ Программа предназначена для отображения на экране текущей ТВ передачи и строки прогресса во времени, а также отображения названия передачи в контекстном меню списка каналов.

  • Папка с файлами баз ТВ программ - Определяет месторасположение файлов базы данных (БД) ТВ программ.
  • Отключить автоматическое отображение ТВ программы в OSD - Запретить отображение в OSD (On Screen Display) блока ТВ Программы при смене каналов.
  • Выводить сообщение, если ТВ программа не найдена или устарела - Если база данных ТВ Программ устарела или не был найден файл связанной программы, будет выдаваться последующее сообщение.
  • Показывать ТВ программу в меню каналов - Отображать название текущей телепередачи и пройденный процент времени в контекстном меню ТВ каналов. Также можно задать максимальное количество символов текста программы, которая будет выводиться в меню.
  • Длина макроподстановки %tvguide% в имени файла - Ограничивает длину строки, при обработке макроса %tvguide% с описанием (названием) телепередачи, включаемую в имя записываемого файла.
  • Файл ТВ программы - Прикрепление файла из БД ТВ программы к выбранному каналу. Также файл можно прикрепить, щелкнув правой кнопкой мыши по нужному каналу и в контекстном меню выбрать требуемый файл.
  • Коррекция времени (минут) - Опция предназначена для подгонки часового пояса под текущий регион. Рядом отображается время коррекции в часах и минутах, а также кнопка, позволяющая применить данную коррекцию ко всем TV каналам.
  • Фильтр по дате - Опция, которая позволяет отфильтровать (только для удобства просмотра списка) весь недельный список программ по заданной дате.
  • Фильтр по контексту - Опция, которая позволяет отфильтровать (только для удобства просмотра списка) весь недельный список программ по заданной контекстной строке. Фильтрация производится динамически в процессе набора текста. В списке будут отображены программы передач, в которых присутствует данная строка.
  • Добавить в планировщик - Команда контекстного меню, с помощью которой можно добавить выбранную телепередачу во встроенный планировщик на любой доступный режим работы. Добавленное задание можно увидеть, открыв планировщик. После добавления задания, рекомендуется выполнить проверку в планировщике на наличие перекрестных заданий.
  • Обновить базы - Вызвать Агент Behold TV и передать ему команду для выполнения ручной загрузки и обновления баз ТВ Программы.

При смене каналов, будет автоматически отображаться блок OSD с ТВ программой. При необходимости, показ можно вывести заново, либо вывести следующую или предыдущую передачу (см. настройку клавиш управления).

При желании, можно произвести автоматический поиск и привязку файлов базы ТВ программы к существующим каналам. Для этого нажмите на кнопку с изображением цепи. Программа будет искать файлы в зависимости от названия существующего канала, по вхождению нескольких символов названия канала в название файла ТВ программы.

2. Закладка по настройке FM каналов (только для модели с FM):

  • Автосканирование FM - Группа для поиска FM станций в заданном диапазоне частот. Для того чтобы начать автосканирование, необходимо нажать кнопку ">>" или "<<". Как только тюнер найдёт работающую станцию, автосканирование остановится. После этого можно нажать кнопку "Добавить", чтобы внести найденную станцию в список, либо нажать кнопку ">>" или "<<" для продолжения сканирования. Чтобы найденные станции автоматически добавлялись в список и автопоиск не останавливался, необходимо установить флажок "Автосохранение". Чтобы очистить список перед добавлением найденных станций, нужно установить флажок "Очищать список". Для корректного автосканирования, необходимо в обязательном порядке использовать FM антенну.
  • Высокая чувствительность при поиске сигнала - Позволяет обнаружить станции, уровень сигнала которых ниже номинального. Побочным эффектом использования этой опции будет большое число найденных "фантомных" каналов.
  • Широкий диапазон для сканирования - Разрешает сканирование в диапазоне 65 - 160 MHz.
  • Основные параметры FM станции - Группа для ручного изменения параметров выбранной станции:
    • Название - Наименование текущей станции.
    • RDS имя - Текст сервиса PSN для RDS станции. Обычно в данном сервисе передается наименование радиостанции. Доступно только для ТВ тюнеров, имеющих функционал RDS.
    • Частота - Частота FM станции. Для тюнеров, имеющих ВЧ блок MK3 и MK5 доступен диапазон настройки от 65 до 880Mhz.
    • Моно - Принудительная установка режима приема в FM Mono. Позволяет снизить шумы стерео станции при неуверенном приеме. Для тюнеров, имеющих ВЧ блок MK2 и MK3, режим Моно также улучшает качество приема. В статусной полоске отображается текущий реальный режим приема. Для тюнеров с поддержкой RDS и имеющих ВЧ блок MK5 не рекомендуется устанавливать принудительно режим Моно, это может привести к ухудшению приема RDS потока на данном канале.
    • Предусиление ПЧ тюнера - Включает усиление промежуточной частоты (ПЧ) радиоблока, позволяя улучшить прием некоторых станций, работающих в пограничных условиях приема и уменьшить визг от самовозбуждения приемника. Побочным эффектом данной опции является усиление шумов. Для мощных станций рекомендуется отключать данную опцию. При настройке на частоты выше 108 МГц, предусиление должно быть обязательно включено, в противном случае чувствительность будет очень низкой. Данная опция доступна только для тюнеров, имеющих ВЧ блок MK3 и MK5.
  • Громкость - Громкость и баланс линейного входа для выбранной станции. Данные настройки могут быть недоступны, если на закладке Аудио установлен "Режим управления громкостью" как "Общая громкость для всех каналов".
  • Тембр - Подстройка тембра ВЧ и НЧ для выбранного канала. Доступно только для чипсета SAA7135.
  • Звуковой эффект - Установка виртуального звукового эффекта для выбранного канала. Доступно только для чипсета SAA7135.

Флажок напротив каждого канала позволяет разрешать или пропускать канал при перелистывании каналов.
Кнопки [image] , [image] и [image] позволяют добавить, вставить и удалить выбранный канал из списка каналов. Для создания, выбора, удаления профиля каналов, необходимо кликнуть по кнопке [image] , и выполнить требуемое действие.

Примечание: При первом запуске программа по умолчанию предлагает список радиостанций, которые можно принимать в Москве и Московской области на индивидуальную радиоантенну. Если вы проживаете в другом регионе, то список радиостанций, скорее всего, необходимо будет перенастроить, либо создать профиль радиостанций для своего города.. Список радиостанций, приведённый в программе по умолчанию, может периодически меняться и дополняться.

3. Закладка настроек НЧ видео входов (VHS/S-VHS):

Данная закладка предназначена для настройки параметров для входов VHS (Композитный вход) и S-VHS (Вход SVideo).

  • Видео стандарт - Настройка видеостандарта для выбранного входа. По умолчанию установлен Autodetect (Автоопределение). Можно принудительно вручную установить желаемый стандарт (PAL/SECAM/NTSC/PAL 60). Ниже, в информационной рамке отображается реально декодируемый стандарт на текущий момент.
  • Синхронизация строк - Подстройка горизонтальной синхронизации (HPLL) видео декодера SAA713x для выбранного входа. Режим VCR предназначен для синхронизации сигнала, подаваемого с VHS ленты видеомагнитофона. Для остальных случаев рекомендуется режим Fast track.
  • Режим аудио входа - Настройка параметров аудио линии для выбранного входа. Если аудио вход подключается через один моно разъем (например обычный видеомагнитофон), то нужно установить режим Line Mono (L) или Line Mono (R), в зависимости от способа подключения.
  • Громкость - Громкость и баланс линии микшера для выбранного входа. Данные настройки могут быть недоступны, если на закладке Аудио установлен "Режим управления громкостью" как "Общая громкость для всех каналов".
  • Тембр - Подстройка тембра ВЧ и НЧ для выбранного входа. Доступно только для чипсета SAA7135.
  • Звуковой эффект - Установка виртуального звукового эффекта для выбранного входа. Доступно только для чипсета SAA7135.
  • Видеомикшер - Группа элементов для изменения яркости, контрастности, оттенка (только для PAL/NTSC), насыщенности, резкости и видеоусиления (Gain) для выбранного входа. Рядом расположена кнопка установки всех регуляторов видеомикшера в значение по умолчанию. Регулятор "Видеоусиление (Gain)" доступен только в режиме ручной регулировки видеоусиления. В противном случае работает видео АРУ (AGC - Automatical Gain Control). Дополнительные параметры для подстройки видео АРУ можно найти на закладке Видео.

4. Закладка настроек видео:

  • Информация о ТВ тюнере Behold TV - Отображение информации о текущей модели ТВ тюнера Behold TV, модели чипсета и класса ВЧ селектора.
  • WDM устройство видеозахвата - Позволяет выбрать WDM устройство видеозахвата (используется, если в системе присутствуют несколько устройств видеозахвата, например видеокарты с VIVO или Web камеры). Необходимо выбирать устройство Behold TV. После изменения этого параметра требуется перезапуск программы.
  • Вывод видео - Режим вывода и представления изображения при просмотре. Если видеокарта поддерживает наложение оверлеев в формате YUY2, то режим "Оверлейная поверхность" будет оптимальным. Подавляющее большинство современных видеокарт поддерживают оверлеи YUY2. Если есть проблемы с изображением или отсутствием оного, можно установить режим "Первичная поверхность". Режим "Первичная поверхность" увеличивает загрузку процессора. В режиме вывода "Первичная поверхность" доступна функция использования полупрозрачного видеоокна. Регулировать степень прозрачности также можно колесом мыши над видеоокном (см. настройки управления). Включение прозрачности сильно увеличивает загрузку CPU в зависимости от размера видеоокна и размера видеопотока. Для функции прозрачности рекомендуется видеопоток размером не более 384x288. При переходе на полный экран, прозрачность автоматически блокируется. Внимание! Функция прозрачности не поддерживается в Windows 98/ME.
    Режим "DXVA поверхность" и только он доступен под Windows Vista. В связи со спецификой вывода видео, а также новой технологии Aero, данный режим вывода видео является единственным доступным под Windows Vista и автоматически учитывает активность Aero и использует максимальную доступную скорость работы.
  • Вывод видео через VMR - Использовать Video Mixing Renderer для вывода видеопотока. Рекомендуется. Видеокарта должна поддерживать технологию VMR. Опция доступна только под Windows XP/2003.
  • Отключать Vista Aero - Позволяет при запуске приложения Behold TV отключать Vista Aero и работать в оверлейном режиме. После закрытия приложения, Aero будет автоматически восстановлено. Рекомендуется для слабых систем. Опция доступна только под Windows Vista.
  • Размер видеопотока - Размер формирования кадра WDM драйвером при просмотре. Чем выше разрешение - тем выше качество изображения. Предусмотрены раздельные настройки изображения для оконного и полноэкранного режимов. Если разрешения кадра не совпадает для этих режимов, то при переключении оконного и полноэкранного режимов, будет наблюдаться щелчок. Рекомендуется держать значения оконного и полноэкранного режимов одинаковыми. Рекомендуемые режимы - 704x576 или 768x576 для PAL/SECAM и 704x480 или 720x480 для NTSC.
  • Сохранять уровни видеомикшера для каждого канала - При переключении каналов значение видеомикшера будет применяться к каждому каналу согласно настройкам каждого ТВ канала. Иначе, значение видеомикшера будет общим для всех каналов.
  • Сохранять зум и позицию кадра для каждого канала - При переключении каналов, значение Зума и Позиции кадра, настроенные для изображения в видеоокне, будут сохраняться для каждого ТВ канала. Иначе значение Зум и Позиция будет общими для всех каналов.
  • Видеообработка изображения при просмотре - Данная кнопка вызывает окно диалога настроек видеообработки изображения при просмотре, которое использует подключаемые плагины всевозможных эффектов обработки.
  • Смена разрешения при переходе на полный экран - Устанавливает параметры рабочего стола Windows при переходе программы в полноэкранный режим. Некоторые устаревшие видеокарты не поддерживают наложение оверлея при высоких разрешениях рабочего стола Windows. Решить эту проблему можно, задав разрешение, например 800x600, в которое будет переходить рабочий стол Windows при переключении в полноэкранный режим. Здесь же можно указать частоту смены кадров монитора в Гц (только под Windows 2000/XP/2003)
  • Philips SAA713x - видео опции - Дополнительные аппаратные настройки для чипов Philips SAA713x.
  • Синхронизация кадров - Режим восстановления вертикальной синхронизации при декодировании видеосигнала. Задает режим, при котором чипсет SAA713x восстанавливает вертикальную синхронизацию после потери синхросигнала (например, при переключении каналов). Рекомендуемое значение - "Нормальный трекинг". Режим "Быстрый трекинг" позволяет максимально быстро восстанавливать синхронизацию кадров, однако его следует применять только при качественном видеосигнале с чистыми синхроимульсами. В противном случае возможны подергивания изображения и смещение кадра по вертикали. Режим "Свободный трекинг" отключает принудительную синхронизацию кадров и может пригодиться для просмотра кодированных каналов с криптованными синхроимпульсами. Данный режим может также выручить при записи с низкокачественной VHS видеоленты, с поврежденными метками синхроимпульсов. Режим "Свободный трекинг" не рекомендуется в повседневном использовании, так как вызывает смещение кадра по вертикали при перелистывании ТВ каналов.
  • Авто регулировка видеоусиления - Набор опций для настройки видео АРУ. Видеоусиление имеет 2 режима работы - ручное и автоматическое (АРУ). АРУ не рекомендуется использовать для эфирных ТВ каналов, так как при сильных изменениях уровня входного видеосигнала, возможны скачкообразные изменения яркости. Для каждого ТВ канала можно установить ручной режим видеоусиления, либо АРУ (Авто).
    • Контролировать порог яркости - Режим, при котором видео АРУ будет срабатывать, при превышении яркостной составляющей видеосигнала номинального значения (0 dB). При отключенном параметре возможно "выбеливание" изображения.
    • Контролировать порог цветности - Режим, при котором видео АРУ срабатывает только тогда, когда уровень цветоразностной составляющей видеосигнала превышает динамический диапазон АЦП декодера. Рекомендуется держать включенным.
    • Длинная пауза АРУ в течении VBI - Длинная или короткая пауза перед срабатыванием АРУ. Длинная пауза рекомендуется, если видеосигнал защищен Macrovision.
  • Антиалиас фильтр для SECAM - Чип SAA713x при декодировании видео формата SECAM выдает небольшой артефакт в виде сеточки на границах резкой смены цветов. Особенно артефакт заметен, когда ползунок резкости близок к максимальному значению. Данная опция позволяет уменьшить "сеточку", однако побочным явлением будет незначительное снижение резкости изображения.
  • Параметры PCI DMA контроллера - Блок настроек, позволяющий настроить корректную работу чипсета SAA713x при передачи потоков по шине PCI.
    • Latency timer - Позволяет управлять латентностью при захвате арбитража слота PCI, в котором установлена плата ТВ тюнера. BIOS и драйверы некоторых материнских плат некорректно устанавливают значение PCI Latency timer, что приводит к появлению артефактов в виде вертикальных цветных полос и мусора на экране тюнера. Рекомендуемое значение от 16 до 64 clock. Установленное значение сохраняется в WDM драйвере. Для поддержки опции Latency timer требуется WDM драйвер версии 2.7.1.0 или выше, в противном случае данная настройка будет недоступна.
    • Burst length - Длина пакета DMA транзакции. Рекомендуется Unlimited burst length, однако не все материнские платы корректно работают с Unlimited burst length, что выражается в искажении данных при передаче пакетов через DMA (corrupted buffers). Особенно важно отсутствие corrupted buffers при передаче цифрового MPEG2 потока. Для поддержки опции Burst length требуется WDM драйвер версии 4.3.7.0 или выше, в противном случае данная настройка будет недоступна.
    • FiFo threshold - Порог заполнения блоков буфера FiFo данными. При превышении данного значения PCI мастер будет запрашивать DMA транзакцию через PCI. По умолчанию является значение 32 Dwords (128 байт). На некоторых материнских платах, а в частности с Serial ATA контроллером Silicon Image имеются проблемы с изображением в виде хаотичных тонких белых горизонтальных полос (FiFo overflow), усиливающихся при дисковых операциях чтения/записи. В данном случае рекомендуется установить значение 16 Dwords, либо 8 Dwords.

4.1. Окно настройки видеообработки изображения с использованием плагинов:

Данное окно предназначено для настройки видеообработки изображения при просмотре. Видеообработка реализована методом подключаемых плагинов. В зависимости от самого плагина, он может иметь дополнительный диалог с настройками.

  • Используемые фильтры процессинга - Список подключаемых плагинов для видеообработки и/или наложения всевозможных эффектов. В зависимости от подключенных плагинов можно менять их последовательность выполнения. Также можно временно деактивировать плагин, путем снятия с него флажка. Добавление плагинов процессинга в список производится через меню, вызываемого при нажатии кнопки "+" справа от списка. При этом плагины процессинга (файлы с префиксом BPP_ и расширением dll) должны находиться в директории ..\BeholdTV\Plugins\.
  • Используемый фильтр деинтерлейсинга - Выбор доступного плагина деинтерлейсинга. Выбрать можно лишь один плагин, который будет заниматься деинтерлейсингом. Деинтерлейсинг - это алгоритм удаления артефакта "расческа" (comb), который проявляется при выводе изображения с черезстрочного источника на прогрессивный дисплей компьютера. Деинтерлейсинг работает только при выводе обоих видеополей кадра, т.е. когда высота кадра выбрана как 576 для PAL/SECAM (например 768x576) или 480 для NTSC (например 720x480).
  • Механизм удвоения частоты кадров - Данная опция позволяет управлять частотой кадров при просмотре. Удвоение частоты кадров позволяет добиться большей плавности видео и позволяет получить динамику сцен как на бытовых телевизорах.
    Внимание! Для максимального использования эффекта удвоения частоты кадров, необходимо настроить обновление кадровой частоты монитора (refresh), кратной 25, например 75Hz, 100Hz. При других значениях будут наблюдаться биения (хорошо видно на примере "бегущей строки").
    • Выключен - Используется стандартный прогрессивный вывод видео с частотой кадров в 25 кадр/сек (30 для NTSC). Для устранения эффекта "расчески" в этом режиме требуется программный деинтерлейсинг.
    • Программный режим удвоения частоты кадров (Smart Interleave) - Используется программный механизм для увеличения кадровой частоты в 2 раза. При этом повышается загрузка CPU (в ~1.5 раза). Для устранения эффекта "расчески" в этом режиме требуется деинтерлейсинг. Данный метод удвоения частоты кадров работает только при выводе обоих видеополей кадра (*x576 или *x480).
    • Аппаратный режим удвоения и деинтерлейсинг (Interleaved Bob) - Используются аппаратные возможности видеокарты для вывода интерлейсных чередующихся видео полей в оверлей. Данный метод работает только на видеокартах поддерживающих аппаратно данную возможность (все ATI Radeon, все nVidia GeForce). Данный метод не требует использования программного деинтерлейсинга, а также практически не увеличивает загрузку CPU. Этот метод доступен только при выводе видео в Оверлейную поверхность (см. настройки на закладке Видео). Внимание! При использовании аппаратных функций деинтерлейсинга, результат работы этих функций виден только в оверлее и не виден при снятии скриншотов средствами приложения.
      Данный метод рекомендуется для владельцев видеокарт ATI Radeon, совместно с включенной опцией "Использовать VMR". Видеокарты ATI Radeon умеют выполнять метод Interleaved Bob без тремора (дрожания) строк, а также с минимальной потерей четкости по вертикали, так как имеют блок аппаратного попиксельного адаптивного деинтерлейсинга. Для корректной работы функции чередования полей требуется драйвер ATI Catalyst не ниже версии 5.4.
      Видеокарты nVidia GeForce (кроме серии GeForce 6600, GeForce 7800) не имеют полноценного попиксельного деинтерлейсинга и выполняют обычный BOB, вызывающий дрожание (тремор строк) а также снижение четкости по вертикали.
      Под Windows Vista данный метод заблокирован, так как на текущий момент Vista не обеспечивает должной аппаратной обработки несжатых потоков, даже в оверлеях.

Примечание:
На интернет-сайте техподдержки http://tuner.beholder.ru вы можете найти и загрузить дополнительные плагины для Behold TV.

5. Закладка настроек аудио:
Для чипсета SAA7134
Для чипсета SAA7135

Настройка вывода звука чипсетом по шине PCI:

  • Настройка аудио микшера - Параметры приложения для работы совместно с системным звуковым микшером.
    • Микшер воспроизведения - Выбор системного аудиомикшера (если в системе несколько подобных устройств). Нужно выбрать только звуковую карту, к которой подключен ТВ тюнер. Некоторые звуковые карты, например Realtek HD Audio имеют 2 микшера - один для записи, другой для воспроизведения. Необходимо выбрать микшер для воспроизведения (Output). При смене микшера, меняются доступные линии воспроизведения. Для PCMCIA тюнера Behold TV Columbus, выбор микшера недоступен.
    • Линия управления звуком - Выбор линии микшера для регулировки уровня звука. Выбирается та линия, к которой подключен звуковой кабель ТВ тюнера. Обычно это Line-In. В случае активизации вывода звука по шине PCI, данная линия может быть погашена (Mute), для исключения вывода звука от двух источников и появления эха. Внимание! Если "Микшер воспроизведения" или "Линия управления звуком" выбраны неверно, то функции гашения (Mute) и управления громкостью работать не будут. Примечание: Для PCMCIA тюнера Behold TV Columbus, выбор линии недоступен.
    • Управлять общей громкостью аудио микшера - При включении данной опции, громкость в ПО всегда будет регулироваться посредством общей линии (Main) микшера звуковой карты. Функции гашения (Mute) по прежнему будет использоваться на основе выбранной линии управления звуком (либо через DirectSound).
    • Сохранять громкость общей линии в настройках - При включении данной опции, уровень общей линии (Main) микшера звуковой карты будет запоминаться при запуске ПО и восстанавливаться по завершению его работы. При этом уровень громкости будет установлен в соответствии с настройками тюнера, т.е. таким же, каким он был при завершении предыдущего сеанса работы с программой. Если опция Сохранять громкость общей линии в настройках отключена, то при запуске ПО уровень громкости общей линии не изменится. Данная настройка доступна только при включении опции Управлять общей громкостью аудио микшера.
    • Отключать линию управления звуком при выходе - Отключать выбранную линию управления звуком микшера при выходе из программы. Позволяет избавиться от наводок в линию при неактивном тюнере. Опция недоступна, если установлен режим вывода звука через шину PCI.
    • Компенсация фейдера при гашении линии (мс) - Звуковые карты Creative серий SB Live!/Audigy/Audigy2/Audigy4 имеют затухающий эффект (Fade) при гашении линии микшера. Данная опция учитывает этот аспект и компенсирует эффект затухания дополнительной задержкой в 150мс. Значения задержки можно регулировать. Если эта опция будет выключена, то на вышеназванных звуковых картах будут слышны щелчки при переключении каналов (особенно на тюнерах с чипсетом SAA7130). Для прочих звуковых карт эту опцию можно выключить. Опция недоступна, если установлен режим вывода звука через шину PCI.
  • Параметры управления звуком - Блок настроек, позволяющий задать оптимальный режим управления громкостью в приложении.
    • Режим управления громкостью - Выбор режима регулирования общей громкости в приложении. Внимание! На уровень громкости тюнера в режиме просмотра оказывают влияние общие настройки громкости системы, т.е. значения линий Main и Wave системного аудиомикшера, а также уровни декодера чипсета Philips SAA7134/35 в настройках на закладке "Аудио".
      • Общая громкость для всех каналов - Устанавливаемая громкость является общей для всех TV/FM каналов и VHS/S-VHS входов.
      • Относительная громкость для каждого канала - Текущая громкость рассчитывается исходя из общей громкости приложения, с поправкой (в процентах) индивидуально для каждого TV/ FM канала или VHS/S-VHS входа. Относительный уровень громкости для выбранного канала или входа задаётся в меню настройки каналов, либо через дополнительную панель управления приложением.
    • Шаг громкости - Значение в процентах для дискретной регулировки общей громкости.
    • Гашение звука (мс) - Время, на которое будет гаситься звук в момент переключения каналов.
  • Вывод звука чипсетом SAA7134/35 через шину PCI - Включает альтернативный механизм вывод звука с использованием DMA. При этом звук будет оцифровываться чипсетом SAA7134/35 тюнера и передаваться по шине PCI непосредственно в буфер звуковой карты. В этом случае аналоговый звуковой кабель, соединяющий ТВ тюнер и звуковую карту, не нужен.
    Примечание: PCMCIA тюнер Behold TV Columbus всегда использует оцифровку и вывод звука чипсетом по шине PCMCIA.
    • DirectSound устройство вывода звука - Выбор DirectSound устройства для вывода цифрового звука. Если в системе одно устройство вывода звука, достаточно выбрать "Первичный звуковой драйвер".
    • Частота выборки семплов декодера (Гц) - Выбор частоты дискретизации звукового потока при передаче через PCI. Доступно только для SAA7135. Рекомендуется частота 48000 Гц.
    • Отключать линию микшера для гашения звука по кабелю - Если аналоговый проходной звуковой кабель подключен во время передачи звука по шине PCI, то будут слышны сразу 2 звуковых потока, со смещением во времени. Для того чтобы звук передающийся по кабелю отключался автоматически, необходимо активировать данную опцию. Примечание: На PCMCIA тюнере Behold TV Columbus эта опция не доступна.
    • Объемный звук (Philips SAA7135 Dolby Pro Logic) - Задействовать процессор Dolby Pro Logic в чипсете Philips SAA7135. Данная возможность доступна только для SAA7135, а также при наличии звуковой карты, поддерживающей вывод каналов по схеме 5.1 либо 6.1 либо 7.1 и только при активированном режиме 5.1/6.1/7.1. Процессор Dolby Pro Logic (DPL) аппаратно раскладывает стерео сигнал на 4 канала - Front Left, Front Right, Front Center, Back Surround, используя запатентованный алгоритм Dolby Pro Logic. Для корректного вывода звука по схеме Dolby Pro Logic, собственный режим работы Surround у звуковой платы (обычно он программный) должен быть отключен, иначе он будет подменять Dolby Pro Logic на собственный алгоритм. Ограничения. Чипсет SAA7135 построен так, что при активации процессора Dolby Pro Logic, сигнал внутри DSP не заводится на блок регулировки Общего уровня, Тембра ВЧ и НЧ, Виртуальных эффектов, звукового АРУ. Также во время записи звука по шине PCI, процессор DPL отключается, для корректной записи стереоканалов в файл.
      • Full surround (Left - Right - Center - Back Surround) - Полный режим работы DPL. Если исходный сигнал является Моно, то после обработки будет работать только центральный канал Front Center.
      • Phantom Center (Left - Right - Back Surround ) - Канал Front Center отключен и распределение панорамы производится в каналы Front Left, Front Right, Back Surround. Если исходный сигнал является Моно, то после обработки будут работать каналы Front Left и Front Right.
      • X3 Stereo (Left - Right - Center) - Канал Back Surround отключен и распределение панорамы производится в каналы Front Left, Front Right, Front Center. Если исходный сигнал является Моно, то после обработки будет работать только центральный канал Front Center.
  • Philips SAA713x - аудио опции - Дополнительные аппаратные настройки чипсетов Philips SAA713x:
    • Промежуточная частота TV звука (SIF) - Блок настроек, позволяющих установить оптимальный уровень сигнала промежуточной частоты (ПЧ) ТВ звука, для его дальнейшего декодирования (только для SAA7134/35). Данные настройки влияют на дальнейшее качество декодирования аудиосигнала чипсетом SAA7134/35. Перегрузка уровня сигнала с SIF выхода, либо недостаточный уровень сигнала, вызывают характерные неприятные щелчки звука, особенно заметные при декодировании NICAM. Декодер NICAM очень чувствителен к входному уровню SIF.
      • Входное усиление - Три режима предварительного усиления, для задания номинального уровня сигнала с SIF выхода ВЧ блока.
      • Автоуровень - Включить автоматическую регулировку уровня сигнала, поступающего с SIF выхода. Рекомендуется. При выключенной опции можно вручную выставить уровень SIF сигнала.
    • Уровень громкости декодера - Задать уровень аудиодекодера для разных линий. Только для SAA7134/35.
      Для SAA7134:
      Линия Main регулирует общую громкость выхода, линия A2/Mono - уровень громкости в системе DualFM, линия NICAM - уровень громкости в системе NICAM. Если в текущий момент нет трансляции NICAM, то этот бегунок будет недоступен. Аналогично и для A2/Mono. Линия PCI позволяет отрегулировать уровень звука при записи звука чипсетом по шине PCI. Все данные регулировки работают только в ТВ режиме (ограничения SAA7134).
      Для SAA7135:
      Линия Main регулирует общую громкость. Данная регулировка работает во всех режимах. Линия A2/Mono, линия NICAM работают только в ТВ режиме для соответствующих стандартов. Линия FM - регулирует громкость c FM тюнера в режиме FM радио, Линия Line - регулирует громкость c линейного входа (режимы VHS, S-VHS). Все регулировки также имеют силу при записи чипсетом звука по PCI.
    • АРУ звука - Автоматическая регулировка выходной громкости звука. Только для SAA7134/35.
    • Чувствительность - Чувствительность аналогового входа для разных режимов. Если громкости не достаточно, то нужно установить 1 Vrms. Для чипсетов SAA7134/35 данная опция недоступна в ТВ режиме.
  • ВЧ радиомодуль - аудио опции - Данный блок настроек доступен только для ТВ тюнеров, имеющих ВЧ селектор класса MK3 или MK5, а также для PCMCIA тюнера Behold TV Columbus в режиме FM.
    • Автогашение звука при слабом сигнале (FM) - При включении этой опции, ВЧ блок гасит выходной сигнал звука, если входной IF уровень ниже критического значения. Это позволяет гасить неприятный шум при отсутствии сигнала. Данная опция доступна только в FM режиме для ВЧ блока MK3/MK5.
    • Уменьшение ВЧ-шума при слабом сигнале (FM) - Опция применима только к Behold TV Columbus в режиме FM и задает параметр HCC (High Cut Control) FM декодера Philips TEA5767. При включении этой опции будут отсекаться высокие частоты звука на FM станциях с плохим уровнем сигнала, для уменьшения эффекта "шипения".
    • Автогашение звука при слабом сигнале (TV) - Аналогичная опция, только для TV режима. Данная опция доступна только для ТВ тюнеров на чипсете SAA7130 + ВЧ блок MK3/MK5 и только в ТВ режиме.
    • Коррекция высоких частот звука (TV) - При включении этой опции подавляются ВЧ составляющие аудио сигнала. Данная опция доступна только для ТВ тюнеров на чипсете SAA7130 + ВЧ блок MK3/MK5 и только в ТВ режиме.

6. Закладка настроек интерфейса:

  • Выбор языка - Выбор языка интерфейса. Файлы ресурсов для поддержки языков находятся в папке \LangRes.
  • Отключать хранитель экрана при активном видеоокне - Отключать хранитель экрана и энергосбережение монитора в режимах TV, CVBS (Composite), S-Video при активном видеоокне.
  • Отображать бордюр вокруг видеоокна - Отображать видеоокно с бордюром.
  • Блокировать вывод видеоокна за пределы экрана - Ограничивать позиционирование видеоокна в пределах экрана.
  • Прилипание окон к границам рабочего стола - Включить эффект "прилипания" видеоокна и главной панели к границам рабочего стола.
  • Показывать кнопку приложения в панели задач - Показывать кнопку приложения в панели задач. Также эта опция разрешает переключаться по Alt+Tab.
  • Кнопка [x] на главной панели для сворачивания в трей - При нажатии кнопки "[x]" (Закрыть) на главной панели выполнять команду "Убрать в трей" (режим ожидания).
  • Загружать Behold TV в трей при старте Windows - Автоматически запускать программу при старте Windows и сворачивать её в трей (режим ожидания).
  • Загружать Агента при старте Windows - Автоматически запускать Агента Behold TV при старте Windows. См. описание Агента.
  • Выключать компьютер при выходе - Автоматическое выключение компьютера при выходе из программы. Если опция включена, то при выходе из программы будет выдаваться сообщение с таймером на 15 секунд с предупреждением о выключении. На данном этапе можно отказаться от выключения или снять опцию выключения при выходе.
  • Блокировать поток просмотра при старте записи из трея - При включении данной опции, если программа находится в режиме ожидания (свернута в трей), то при вызове записи из встроенного планировщика, поток просмотра будет принудительно отключен, для снижения нагрузки на систему. Предполагается, что в этом случае программа работает в отсутствии пользователя. Если просмотр необходим, следует отключить данную опцию.
  • Блокировать смену ТВ и FM каналов в режиме записи - Опция запрещает переключение каналов, если активен процесс записи видео или аудио (кроме режима трансляции в IP сеть).
  • Режим серфинга, ячеек - Количество ячеек в мозаике при серфинге каналов.
  • Интервал серфинга - Время в секундах, отводимое на просмотр каждой ячейки.
  • Задержка выбранной ячейки (с) - Время в секундах, отводимое на повторный показ изображения в ячейке, по которой произвели клик мышью. Значение 0 - ручной режим, серфинг не будет продолжаться до тех пор, пока не будет произведен повторный клик по данной ячейке.
  • Начинать серфинг с первого канала - При старте серфинга переключаться на первый канал в списке.
  • Показывать каждый канал в своей ячейке - При серфинге, каждый канал будет отображаться строго в своей ячейке. В данном режиме желательно обеспечить количество ячеек не меньше количества каналов.
  • Использовать внешнюю программу телетекста - Использование внешней альтернативной программы телетекста. При нажатии на кнопку TEXT с главной панели будет вызываться указанное приложение.
  • Хранить настройки раздельно для каждого профиля - По умолчанию программа хранит все свои настройки в ini и cfg файлах в текущей папке приложения. При использовании нескольких учетных записей на одной системе (только под Windows 2000/XP/2003/Vista), можно использовать раздельное хранение настроек программы под каждыми профилями пользователей. При этом файлы настроек будут храниться в папках "C:\Documents and Settings\[Имя пользователя]\Application Data\BeholdTV\". Данный функционал также позволяет работать пользователям не имеющих прав "Администратор" совместно с пользователями имеющими такие права. Как известно, при использовании файловой системы NTFS, по умолчанию пользователю не имеющему права "Администратор" запрещена запись в файлы, созданные пользователем с правами "Администратор".
    Внимание! Windows Vista использует User Account Control (UAC), который понижает привилегии пользователя и даже пользователю с правами Администратора блокирует доступ на запись к большинству системных папок, в том числе к папке Program Files. Поэтому для нормальной работы под Windows Vista данная опция должна быть включена, в противном случае приложение не сможет сохранять свои настройки. Файлы настроек в Windows Vista будут при этом храниться в папках "С:\Users\[Имя пользователя]\AppData\Roaming\BeholdTV\".
  • Приоритет программы при просмотре - Приоритет основного процесса при просмотре (не влияет на приоритет при захвате).

7. Закладка настроек функции Таймшифт:

Для ТВ тюнеров без аппаратного MPEG энкодера::

Для ТВ тюнеров с аппаратным MPEG энкодером:

Таймшифт - это функция, которая по аналогии с паузой при просмотре/прослушивании обычной видео- и аудиозаписи, позволяет приостанавливать воспроизведение телевизионных или радиопрограмм, транслируемых в реальном режиме времени, для того, чтобы отложить их просмотр на некоторое время, не прибегая к обычно используемой для этих целей записи.

  • Статус готовности режима "Таймшифт" - Для работы функции Таймшифт требуется два установленных компонента - MPEG2 энкодер и MPEG2 декодер. Если какой-либо из компонентов не установлен, либо имеет устаревшую версию, функция Таймшифт будет недоступна. Оба компонента - InterVideo MPEG2 Encoder и Decoder устанавливаются при установке приложения InterVideo WinDVD Creator, поставляемого на отдельном диске в комплекте с тюнером Behold TV. Для тюнеров с аппаратным MPEG энкодером необходим только один компонент - MPEG2 декодер.
    Приложение Behold TV может использовать различные MPEG2 декодеры, установленные в системе, но только лишь те, которые определены в дескрипторах "MPEG2.audiodecoders.ini" и "MPEG2.videodecoders.ini" находящиеся в папке \BeholdTV\Decoders. В данных дескрипторах по умолчанию внесены описания декодеров, которые были тщательно оттестированы на совместимость и обеспечивают высокое качество декодирования без каких-либо видимых проблем.
    В Windows Vista поставляются новые высококачественные MPEG2 декодеры от Microsoft, которые можно использовать, выбрав в списке вместо InterVideo декодеров. Для ТВ тюнеров с аппаратным MPEG2 энкодером под Windows Vista достаточно будет использовать декодеры Microsoft, при этом отпадает необходимость в установке InterVideo WinDVD Creator как приложения (если оно не требуется пользователю) . Если MPEG2 аудио/видео декодер имеет стандартный DirectShow диалог конфигурации, то его можно вызвать по нажатию кнопки свойств напротив декодера и настроить декодер по своему усмотрению. Необходимо понимать, что каждый декодер имеет свой уникальный диалог настроек, свойственный только данному декодеру. Если аудиодекодер имеет поддержку декодирования AC3, то для тюнера Behold TV M6 Extra будет доступен выбор аудиоформата кодирования звукового потока.
  • Папка для хранения временного файла - Выбор папки, куда будет записываться временный файл при работе функции Таймшифт. Для работы Таймшифт на диске должно быть достаточно свободного места, желательно не меньше 4 Гб.
  • Оставлять временный файл таймшифта - После окончания работы функции Таймшифт, временный файл будет сохраняться на диске для возможного последующего его просмотра.
  • Раздельные процессы на запись и воспроизведение - Параметр, позволяющий в многозадачной системе возложить запись и воспроизведение файла в режиме Таймшифт на два независимых процесса. При этом за счёт более гибкого распределения ресурсов процессора(ов) обеспечивается большая плавность при просмотре Таймшифт. Примечание. Данный параметр не актуален для тюнеров с аппаратным MPEG2 энкодером.
  • Автоматический запуск воспроизведения - После нажатия на кнопку "Таймшифт", воспроизведение запустится автоматически.
  • Отключать видеообработку для просмотра - Не использовать видеообработку с подключаемыми плагинами во время работы функции Таймшифт. Для тюнеров с аппаратным MPEG энкодером рекомендуется отключать видеообработку, для того чтобы задействовать DXVA - аппаратное ускорение процедуры iDCT (обратное дискретно-косинусное преобразование), которое будет исполняться на стороне видеокарты, снижая загрузку CPU при декодировании MPEG2 видео и активируя режим чередования полей и адаптивный деинтерлейсинг, что обеспечит более комфортный просмотр интерлейсного видео на современных видеокартах.
  • Параметры записи видео - Настройки видео кодека при кодировании и записи видео потока на диск. Предусмотрены готовые сбалансированные пресеты, однако при желании можно настроить свою схему. Примечание. Тюнеры с аппаратным MPEG2 энкодером имеют собственные настройки, отличные от программного энкодера.

    Пресет видеозаписи

            Минимальный CPU Intel Минимальный CPU AMD
    Плохое качество | PIII 550-600 | Duron 600-700
    Низкое качество | PIII 650-733 | Duron 750-800
    Среднее качество | PIII 800-850 | Duron 900-1000
    Хорошее качество | PIII 1200, P4 1600 | Duron 1600, Athlon XP 1700+
    Высокое качество | P4 2400 | Athlon XP 2500+
    • Размер кадра - Выбор размера кадра перед кодированием и записью на диск. Чем больше размер кадра, тем более мощный CPU требуется для кодирования.
    • Битрейт (Кбит/с) - Скорость записи кодируемого видеопотока. Чем выше битрейт, тем выше качество изображения при большем размере записываемого файла.
    • Векторы движения - Чем выше векторы движения, тем меньше будет блочных артефактов на быстродвижущихся сценах. Чем выше векторы, тем больше загрузка CPU.
  • Параметры записи аудио - Настройки аудио кодека при записи потока на диск. Также предусмотрены готовые сбалансированные пресеты, однако при желании можно настроить свою схему. Кодирование аудио потока не требует больших вычислительных ресурсов. Примечание. Данные параметры не актуальны для тюнеров с аппаратным MPEG энкодером.
    • Режим кодирования - (Dual Channel, Stereo, Joint Stereo, Mono).
      Dual Channel - режим, при котором левый и правый каналы кодируются раздельно, как две разные записи. На каждый из каналов отводится ровно половина размера результирующего файла. Используется очень редко, например, когда в одном канале идет дикторский текст, а в другом - музыка. Для этого режима требуется битрейт не ниже 320 Кбит/с.
      Stereo - в этом режиме каналы также кодируются раздельно, однако кодер в ходе работы может варьировать распределение потока и в зависимости от ситуации увеличивать или уменьшать пропускную способность одного из каналов за счет другого. Это предотвращает, например, кодирование "тишины" в отдельном канале, в то время как в соседнем содержится сигнал.
      Joint Stereo - в этом режиме левый и правый каналы кодируются вместе, а в результирующий файл записывается информация о разности в двух каналах, например, левый канал и отличия правого канала от левого. Joint Stereo позволяет более качественно закодировать поток с низким битрейтом (будет больше высоких частот), однако ухудшается передача стереоэффектов.
      Mono - в этом режиме кодируется только среднее значение обоих каналов.
    • Битрейт (Кбит/с) - Скорость записи кодируемого аудиопотока. Чем больше битрейт, тем выше качество звука. Для режима кодирования "Mono" максимальный битрейт 192 Кбит/с.
    • Частота выборки (Гц) - Чем выше частота выборки, тем больше высоких частот будет в закодированном файле.
  • Записывать звук чипсетом SAA7134/35 через PCI - Эта опция разрешает оцифровку и запись звука чипом SAA7134 или SAA7135 вместо звуковой карты. Данная опция может быть применена, если звуковая карта не умеет производить одновременно запись и воспроизведение звука (не поддерживается Full Duplex), либо драйвера звуковой карты не позволяют корректно отключать линию воспроизведения во время записи. Примечание. Данный параметр не актуален для тюнеров с аппаратным MPEG энкодером.

В нижней части панели отображается справочная информация о предполагаемой длительности режима Таймшифт, в зависимости от свободного места на диске и используемого битрейта. Необходимо помнить, что в файловой системе FAT32 размер файла не может превышать 4 ГБ, поэтому длительность рассчитывается исходя из максимального значения 4 ГБ. Для более длительной работы требуется файловая система NTFS (только под Windows 2000/XP/2003).

Внимание! При работе функции Таймшифт, приложение отключает основной канал работы с аудиоплатой и выводит звук из записываемого файла. Если при работе Таймшифт прослушиваются два аудиоканала, смещённые один относительно другого по времени, то это означает, что в настройках на закладке "Аудио" неверно выбран "Микшер воспроизведения" или "Линия управления звуком", с которыми работает приложение.

8. Закладка настроек пульта ДУ:

Данная закладка предназначена для настройки команд, выполняемых при нажатии на определенную кнопку пульта ДУ, а также конфигурации параметров ПДУ.

Модели тюнеров, имеющие поддержку технологии ARPC, позволяют добавлять в список любые сторонние ПДУ стандарта NEC, обучать новым командам, редактировать названия кнопок, менять их последовательность в списке, назначать им соответствующие действия. Первый пульт ДУ в списке является родным и не поддерживает никаких изменений, кроме как назначения действий на кнопки.

Для обучения нового ПДУ, необходимо выполнить следующее:

  1. Нажать кнопку "Подключить новый ПДУ" и ввести произвольное имя пульта. Имя не должно совпадать с уже имеющимися в списке.
  2. Нажать кнопку "Обучать/редактировать". В этом режиме приложение ожидает от пользователя нажатия кнопок обучаемого ПДУ. При получении от ПДУ кода клавиши, новая строка добавится в список. При желании можно изменить название кнопки, дважды кликнув мышью на ячейке с именем кнопки. На данном этапе также можно назначить действие на текущую обученную кнопку, либо оставить это на потом. Повторить обучение для всех требуемых кнопок данного ПДУ. При необходимости можно удалить обученную кнопку, подсветив строку и нажав клавишу Delete.
  3. Отжать кнопку "Обучать/редактировать". Приложение перейдет в обычный режим. Можно отсортировать кнопки в таблице, потянув мышью требуемую строку за первый столбец и перекинув строку в нужную позицию.
  4. Назначить действия на кажду кнопку (если еще не назначены).
  5. Активировать ПДУ, путем установки флажка "Активен".
  6. Сохранить конфигурацию.

При особом желании, можно подключить картинку с изображением нового ПДУ. Для этого необходимо нарисовать или сфотографировать ПДУ и в графическом редакторе уменьшить изображение. Максимально допустимые размеры картинки - ширина 160, высота 206 пикселов. Границы вокруг пульта нужно залить любым ключевым цветом и сохранить файл в формате Вmp. Далее необходимо кликнуть правой кнопкой мыши по месту расположения рисунка ПДУ и выбрать в контекстном меню команду "Добавить картинку...". Выбрав указанный файл, он скопируется в папку с приложением и автоматически будет подключен к текущей конфигурации ПДУ.

Приложение будет реагировать на команды тех пультов ДУ, которые отмечены флажком "Активен".

Для режима активного меню, серфинга ТВ каналов, а также режима "Таймшифт" предусмотрена отдельная настройка действий. При нажатии кнопки на пульте ДУ, маркер автоматически переместится к текущей кнопке в таблице.

Группа "Общие установки" актуальна для всех подключенных ПДУ:

  • Использовать пульт ДУ - Позволяет разрешить или запретить поддержку всех пультов ДУ в приложении.
  • Задержка перед повтором - Время в мс., в течении которого происходит задержка перед автоповтором при нажатии любой кнопки пульта ДУ.
  • Интервал автоповтора - Время в мс., в интервале которого при нажатой кнопке пульта ДУ выполняется автоповтор команды.
  • Включение ПК - Открывает диалог управления включением компьютера (только для тюнеров с поддержкой технологии ARPC).

При нажатии на кнопку "По умолчанию", будут восстановлены настройки команд пульта ДУ (только родного), предустановленные по умолчанию.

8.1 Окно конфигурации управления включением компьютера:

Данное окно диалога предназначено для программирования микроконтроллера ARPC на возможность включения компьютера.

  • Режим включения питания - Определяет режим включения питания компьютера по внутреннему таймеру а также с пульта ДУ.
    • Не использовать (включение запрещено) - Деактивирует функцию включения питания тюнером.
    • Использовать линию PME шины PCI - Компьютер будет включен путем подачи сигнала по шине PCI. Данная функция будет работать при наличии поддержки PME со стороны материнской платы. На большинстве современных материнских плат функционал PME поддерживается.
    • Эмулировать кнопку включения питания АТХ - Компьютер будет включен через кнопку АТХ.
  • Назначенные кнопки ПДУ для включения питания - Программирование до 4 кнопок различных ПДУ, при нажатии которых будет произведено включение компьютера. Те кнопки, которые определены на включение компьютера, будут отображаться в таблице команд ПДУ красным шрифтом. Для программирования кнопки необходимо нажать кнопку диалога "Назначить" у выбранной ячейки и прошить код кнопки путем нажатия ее на пульте ДУ. Если требуется стереть кнопку из ячейки, достаточно отжать кнопку диалога "Назначить". Все изменения будут сохранены после нажатия кнопки диалога "Принять".

Настройки данного диалога будут сохранены даже после полного отключения компьютера от сети питания.

9. Закладка настроек управления:

Данная закладка предназначена для настройки команд, выполняемых при нажатии сочетаний клавиш. Чтобы внести изменение в какую либо ячейку, необходимо два раза кликнуть по требуемой ячейке, либо в контекстном меню ячейки выполнить команду "Разрешить изменение". Далее нужно нажать требуемое сочетание клавиш. Принятое программой сочетание клавиш отобразится в ячейке. После изменения настроек, необходимо нажать кнопку "Сохранить", для того чтобы записать все настройки в файл.

При нажатии на кнопку "По умолчанию", будут восстановлены все настройки клавиш, предустановленные по умолчанию.

Эта закладка предназначена для настройки команд мыши.

При нажатии на кнопку "По умолчанию", будут восстановлены настройки команд, предустановленные по умолчанию.

10. Закладка настроек LCD и OSD:

  • Включить OSD - Разрешить вывод OSD.
  • Тип фона OSD - Режим отображения фона под текстом OSD. Если выбран прозрачный или полупрозрачный режим фона, то для корректного отображения фона требуется активный режим вывода видео в оверлей. В случае отсутствия оверлея, фон будет включен принудительно.
  • Задержка OSD текста - Время отображения обычного OSD текста в секундах.
  • Задержка OSD меню - Время отображения расширенного OSD (меню видеомикшера, меню списка ТВ каналов, меню списка ТВ программы) в секундах.
  • Отключать сглаживание шрифта - Отключает сглаживание TrueType шрифтов при выводе OSD. Функция работает только при включенном режиме сглаживания шрифтов в Windows.
  • Отключать статистику при записи - Не выводить в полноэкранном режиме в OSD информацию о процессе записи.
  • OSD для ТВ программы - Группа настроек для отдельного конфигурирования вывода OSD при показе блока информации ТВ Программы.
    • Задержка ТВ Программы - Время отображения блока ТВ Программы в OSD.
    • Максимум строк текста - Лимит выводимых строк с текстом описания телепередачи.
    • Выводить информацию о канале - Выводить в первой строке название ТВ канала и процент прошедшего времени текущей телепередачи.
  • Установки LCD - Группа настроек для конфигурирования LCD дисплея.
    • Интервал скроллинга (мс) - Периодичность скроллирования строки текста в LCD дисплее.
    • Файл шрифта для поддержки языка - Для правильного отображения шрифта на LCD дисплее требуется поддержка языков, отличных от Английского.

Примечание:
Для изменения шрифта OSD необходимо кликнуть мышью по соответствующей надписи "OSD". Для изменения цвета выбранного параметра, необходимо кликнуть мышью по соответствующему цветному паттерну.


Capture panel

Behold TV - Панель записи

Все настройки по записи изображения и звука размещены на отдельной панели записи.

Основная закладка записи:

Данная закладка служит для управления режимами записи, а также для отображения статистики в процессе видео/аудио или аудио записи.

В правой верхней части располагается монитор уровня записи аудио, который позволяет визуально контролировать процесс записи звука. Монитор показывает пиковое значение амплитуды сигнала текущего аудиоустройства. Текущим считается то устройство, которое в данный момент работает со звуком. Т.е., если для просмотра используется передача звука по аудиокабелю через звуковую плату (режим "Передавать звуковой поток по шине PCI" в настройках "Аудио" тюнера отключен), то до старта записи текущим устройством будет считаться звуковая плата. После старта записи с настройкой "Запись звука чипсетом SAA7134/35 через PCI" текущее устройство сменится на "Philips SAA7135HL" или "Philips SAA7134HL". При этом уровень записи, скорее всего, будет уже другим. Таким образом, если для записи и просмотра используются разные устройства, то корректная настройка уровня записи возможна будет только в процессе записи.

Для уменьшения загрузки процессора и во избежание проблем с некоторыми звуковыми картами, которые могут некорректно работать в режиме двухпоточности при индикации уровня во время записи, монитор уровня записи аудио можно отключить.

В нижней левой полосе статуса отображается текущее устройство записи звука, в нижней правой полосе статуса - текущее полное имя и путь записываемого файла.

Режим вещания в сеть (Network Broadcast)

В случае записи видео или аудио в режиме трансляции (вещания) в IP-сеть, в нижней правой полосе статуса будет отображен URL адрес для подключения клиентов. Данный адрес, а также другие адреса для текущего хоста можно скопировать в буфер обмена по контекстному меню мыши над полосой статуса. При нажатии на мини-кнопку над числом подключенных клиентов, можно увидеть детальную информацию о каждом подключенном клиенте.

Для того, чтобы клиенту подключиться к серверу вещания, нужно запустить Windows Media Player, в меню выбрать "Файл", "Открыть адрес URL..." и в появившемся диалоге ввести URL до сервера в виде http://адрес:порт, например http://192.168.3.150:8080. На текущем сервере вещания можно подключиться к самому себе, используя loopback - http://127.0.0.1:порт, либо что тоже самое - http://localhost:порт.

Для того чтобы клиенту подключиться к серверу вещания, используя Nullsoft WinAmp (http://www.winamp.com), нужно в меню WinAmp выбрать "File", "Play URL" и в появившемся диалоге ввести вышеуказанным способом URL, дополнительно добавив нужное расширение со звездочкой (*.wma или *.wmv), например http://192.168.3.150:8080/*.wma.

При трансляции в IP сеть MPEG потока по UDP Multicast протоколу, на клиентской машине требуется проигрыватель, умеющий принимать UDP Multicast поток MPEG. Наиболее широко распространенным является проигрыватель VLC Media Player (http://www.videolan.org). Чтобы открыть поток в VLC Media Player, необходимо в меню "Файл" выбрать команду "Открыть URL...", выбрать радиокнопку "UDP/RTP Multicast", ввести IP адрес Multicast группы и номер порта. Данные значения должны быть взяты c транслирующего компьютера, из строки URL статуса Behold TV.

Закладка настроек видео/аудио записи:

  • Пресеты для видео/аудио записи - Список заготовленных пресетов для видео записи, в которых находится заранее настроенная конфигурация. При помощи пресетов можно быстро загружать нужные настройки записи. Пресеты можно создавать самому, удалять, перезаписывать содержимое. Если файл пресета имеет атрибут "Только для чтения", то кнопка удаления пресета будет недоступна. Для того чтобы создать новый пресет, нужно выставить требуемые настройки на текущей закладке, нажать кнопку "Сохранить" и выбрать имя для пресета.
  • Способ видеозаписи - Формат записи видео. Поддерживаются несколько способов - "Microsoft AVI", "Microsoft ASF", "Microsoft WMV", "Software MPEG", "Hardware MPEG2 DVD". Для того чтобы была возможность записывать в формате "Software MPEG", необходимо установить InterVideo WinDVD Creator со второго диска, прилагаемого к ТВ тюнеру. Для того чтобы была возможность записывать в форматах "Microsoft ASF", "Microsoft WMV", требуется Windows XP SP2 и выше, либо установленный апдейт Microsoft Windows Media Format Runtime версии 9 или выше. Способ видеозаписи "Hardware MPEG2 DVD" доступен только на ТВ тюнерах с аппаратным энкодером. Каждый способ записи имеет собственные настройки:

Microsoft AVI - Самый распространенный универсальный формат записи видео/аудио. Он имеет следующие настройки:

  • Размер кадра - Разрешение видеокадра при записи. Внимание!. Размер кадра не может быть произвольным. При выборе разрешения, нужно руководствоваться следующим:
    1) Высота кадра должна быть кратна размеру видеополя. Для PAL/SECAM одно поле занимает 288 строк, для NTSC - 240. Таким образом, высота может иметь всего несколько значений - 144, 288, 576 для PAL/SECAM и 120, 240, 480 для NTSC.
    2) Ширина кадра должна быть кратна как минимум 4, желательно 8.
    Список наиболее распространенных размеров кадра выводится по правому клику мыши.
  • Формат - Наиболее предпочтительным форматом для записи является YUY2, однако, для достижения максимального качества изображения можно использовать формат RGB24, при этом загрузка процессора будет выше и конечный файл будет большего размера. Следует учитывать, что некоторые кодеки не поддерживают формат RGB24.
  • Кадр/сек - Частота смены кадров в записываемом видео. В зависимости от текущего формата (NTSC или PAL/SECAM), частоты кадров данного списка будут скорректированы автоматически (делитель останется неизменным). Следует понимать, что в данной настройке актуальна не абсолютная частота кадров, а делитель от оригинальной частоты кадров. Делитель для PAL/SECAM/NTSC стандартов будет единым. Пониженные частоты (1/2 и 1/5) могут понадобиться, например, для записи совместно с охранным плагином, чтобы снизить битрейт и место на диске.
  • Сжатие видеопотока - Позволяет выбрать для сжатия видео любой зарегистрированный в системе VCM или DirectShow видео кодек. Такие кодеки выпускаются и распространяются сторонними производителями программного обеспечения и устанавливаются в систему пользователем самостоятельно.
    Прежде чем использовать выбранный кодек, необходимо ознакомится с его настройками, параметрами и свойствами. Описание и все технические характеристики кодека должны предоставляться производителем кодека.
    Программное обеспечение Behold TV работает с VCM кодеками в соответствии правилами и спецификациями, оговариваемыми стандартами Microsoft VfW, и предъявляет к кодекам самые минимальные требования. Кодек должен поддерживать форматы данных YUY2/RGB24 и работать со всеми возможными разрешениями кадра. Если выбранный кодек не поддерживает каких-либо параметров, устанавливаемых программой, или не полностью соответствует спецификации MS VfW, то стабильная работа приложения Behold TV в данном случае не гарантируется.
    Необходимо помнить, что у VCM и DirectShow кодеков может быть набор собственных параметров, доступных при нажатии на кнопку Свойства видео кодека. Настройки этих параметров определяют его производительность, качество кодирования и, в некоторой степени, могут влиять на стабильность работы системы в целом.
    Ряд VCM кодеков имеют возможность сохранять настройки своих параметров в соответствии со спецификацией MS VfW. Программное обеспечение Behold TV по возможности использует это свойство, что позволяет сохранять настройки кодеков индивидуально для каждого пресета записи.
    Производитель кодека от версии к версии может по своему усмотрению вносить изменения в блок сохраняемых данных и в его обязанность входит следить за тем, чтобы новые версии кодеков были совместимы по этим параметрам.
    Рекомендуемые кодеки:
    1) Низкая степень сжатия без потерь - Huffyuv, PICVideo Lossless JPEG.
    2) Средняя степень сжатия - PICVideo MJPEG, Morgan MJPEG v3, MainConcept DV.
    3) Высокая степень сжатия - XviD 1.x.x, DivX 5/6, WMV9 VCM, On2 TrueCast VP6/7.
  • Формат/сжатие аудио потока - Выбор формата и тип сжатия для аудио потока. Рекомендуемый формат - PCM. Сжатие звука в отличных от PCM форматах может приводить к рассинхронизации аудио и видео потоков. При установленной галочке "Запись звука чипсетом SAA7134/35 через PCI", список доступных форматов без применения конвертации будет ограничен частотами 32/44.1/48кГц для чипсета SAA7135 и 32кГц для чипсета SAA7134.
  • Режим чередования - Указывает модулю AVI Mux DirectX, каким образом располагать аудио и видео данные в записываемом файле. Значение по умолчанию - "None".
    • None – Аудио и видео данные будут записываться в файл в порядке их поступления от аудио и видео кодеков. Из-за особенностей работы и настроек некоторых кодеков аудио и видео данные могут задерживаться и поступать в AVI Mux неравномерно. В результате структура видеофайла получается достаточно хаотичной и непредсказуемой, что может создать сложности при просмотре такого файла и его редактировании.
    • Full – AVI Mux будет строго следить, чтобы аудио и видео фрагменты чередовались в файле равномерно, в соответствии с их размером и очерёдностью. Однако, это достигается методом ожидания поступления очередных порций данных, что может вызвать переполнение выходного видеобуфера драйвера (см. ниже) и привести к потере кадров при записи.
    • Buffered (XP only) – режим, эквивалентный режиму «None», с той разницей, что данные при записи в файл предварительно буферизуются в памяти. Это снижает нагрузку на дисковую систему за счёт уменьшения количества обращений к накопителю. Режим доступен в XP и более старших версиях операционных систем.
  • Главный поток - Настройка модуля AVI Mux DirectX, который, также, отвечает за синхронизацию аудио и видео данных при записи AVI. При оцифровке звука аудиокартой в качестве настройки главного потока желательно указывать режим «Audio», т.к. из-за незначительных отклонений частот оцифровки от номинальных значений теоретически возможна рассинхронизация аудио и видео потоков в записанном файле. В режиме «Audio» AVI Mux будет подгонять скорость воспроизведения видео к скорости аудио, в результате чего возможно незначительное отклонение среднего значения частоты кадров в ту или иную сторону. Это может привести к проблемам при дальнейшем редактировании и сшивке AVI файлов.
    При оцифровке звука чипсетом SAA713x тюнера входные аудио и видео потоки абсолютно синхронны и в настройке главного потока AVI Mux можно указать режим «None». Однако, из-за особенностей работы некоторых кодеков синхронность потоков на входе мультиплексора AVI Mux может быть нарушена. Это приведёт к рассинхронизации звука и видео в записанном файле. В подобном случае может помочь установка главного потока «Audio» или выбор другого кодека.

Выбор и конфигурация ACM кодека:

Данный диалог представляет собой выбор установленного в системе ACM кодека, его конфигурирование и выбор доступного формата. Если включена опция записи звука чипсетом SAA7134/35 по шине PCI, то в данном списке часть форматов будет окрашена в другой цвет. Это означает, что при записи в данный формат будет выполняться программное конвертирование частоты дискретизации из исходного PCM формата чипсета в требуемый формат, при этом будет наблюдаться небольшое ухудшение качества. Рекомендуется использовать только нативные форматы, отображенные черным цветом. Это 32кГц Стерео для чипсета SAA7134 и 32/44.1/48кГц Моно/Стерео для чипсета SAA7135. Частота дискретизации 44.1кГц для чипсета SAA7135 не доступна нативной в режиме ТВ.

Software MPEG (InterVideo) - Способ записи видео/аудио в распространенный мировой стандарт MPEG1/2. Стандарт MPEG2 используется в DVD проигрывателях, в спутниковом DVB-S и наземном DVB-T/C цифровом телевидении. Он имеет следующие настройки:

  • Режим MPEG - Режим работы MPEG кодера. MPEG1 - это старый формат, который использует для записи всего одно видеополе. Максимальное разрешение 384x288. MPEG1 VCD - это MPEG1 формат, который имеет собственную структуру индексирования а также режим мультиплексирования аудио и видео потока. Данный формат применяется исключительно для создания VCD дисков. Данный формат не поддерживает запись без аудио потока. MPEG2 - более новый формат, поддерживает запись обоих видеополей, имеет более высокий битрейт а также содержит более новые алгоритмы кодирования. Максимальное разрешение кадра 720x576 (720x480). MPEG2 SVCD - MPEG2 формат с собственной структурой индекса, предназначенный для записи на SuperVCD диски (CD 650-800МБ) с высоким качеством. Максимальное разрешение кадра 480x576 (480x480). Максимальный битрейт 2400kBit/s. MPEG2 DVD - MPEG2 формат с собственной структурой индекса, предназначенный для записи на DVD диски с наивысшим качеством. Максимальный битрейт 9600kBit/s.
  • Размер кадра - Разрешение видеокадра при записи. Для каждого формата MPEG имеется собственный набор доступных разрешений кадра.
  • Аспект - Соотношение сторон кадра при проигрывании MPEG2 файлов. Данное соотношение считывается большинством программных MPEG2 проигрывателей (а также стационарными DVD плейерами) для установки требуемого соотношения сторон кадра при выводе изображения.
  • Битрейт видео - Скорость записи видеопотока в файл. Для каждого формата MPEG имеется собственный диапазон доступных битрейтов. Чем выше битрейт, тем выше качество изображения, но больше размер конечного файла. Средний битрейт (3500-4500kBit/s), высокий битрейт (6000-9000kBit/s).
  • GOP/SubGOP - GOP - количество кадров между I-фреймами в MPEG потоке, SubGOP - количество B-фреймов в подгруппе. Чем больше значения GOP и SubGOP, тем меньший поток можно задать при том же качестве, соответственно качество картинки получится выше, но при этом возрастет загрузка процессора. Наиболее качественные результаты получаются при GOP = 15, SubGOP = 3.
  • Векторы движ. - Векторы движения. Чем больше векторов, тем меньше артефактов будет видно на быстродвижущихся объектах и при динамических сменах сцен. При увеличении значений векторов повышается загрузка процессора. Рекомендуемое значение - не меньше 8.
  • Деинтерлейс - При высоте кадра больше 288(240), кодек InterVideo требует использования MPEG деинтерлейса. В противном случае будет виден артефакт "Расческа" и будет более низкое качество сжатия. Режимы "Blend" дают более сглаженное изображение, при незначительном падении четкости. Режим "Median" не снижает четкости, однако дает артефакт "Лесенка" на границах наклонных линий. Можно не использовать встроенные режимы деинтерлейса кодека InterVideo, а использовать методы деинтерлейса из видеообработки на основе подключаемых плагинов.
  • Битрейт аудио - Аудио при MPEG записи записывается в формате MPEG Layer-II. Бирейт аудио определяет скорость записи аудиопотока в файл. Чем выше битрейт, тем выше качество звука. Оптимальный битрейт для MPEG Layer-II принят 224-256 kBit/s.
  • Частота (Гц) - Частота выборки аудиосемплов при аналого-цифровом преобразовании (АЦП). Частота 48000Гц позволяет максимально точно оцифровывать без потерь высокие частоты звука. При установленной галочке "Запись звука чипсетом SAA7134/35 через PCI", список доступных частот будет 32000, 44100, 48000Гц для чипсета SAA7135 и 32000Гц для чипсета SAA7134.
  • Кодирование - Режим кодирования аудиоканалов. Рекомендуемые режимы Stereo и Joint Stereo. В режиме Joint Stereo левый и правый каналы кодируются вместе, а в результирующий файл записывается информация о разности в двух каналах, например, левый канал и отличия правого канала от левого. Joint Stereo позволяет более качественно закодировать поток с низким битрейтом (будет больше высоких частот), однако ухудшается передача стереоэффектов.

Hardware MPEG2 DVD - Способ записи видео/аудио в распространенный мировой стандарт MPEG2 (ISO/IEC13818). Доступен только для ТВ тюнеров с аппаратным MPEG энкодером на борту. Он имеет следующие настройки:

  • Размер кадра - Разрешение видеокадра при записи. Для максимального качества рекомендуется использовать D1 кадр - 720x576 для PAL/SECAM (720x480 для NTSC). При установке размера кадра 352x288 (SIF) будет формироваться прогрессивный MPEG2 видео поток, состоящий из одного видеополя.
  • Аспект кадра - Соотношение сторон кадра при проигрывании MPEG2 файлов. Данное соотношение считывается большинством программных MPEG2 проигрывателей (а также стационарными DVD плейерами) для установки требуемого соотношения сторон кадра при выводе изображения.
  • Аудио формат - Выбор формата аудио потока для кодирования. Доступны форматы:
    • LPCM bypass. Linear Pulse Code Modulation. Несжатый поток с линейным квантованием. LPCM понимают большинство стационарных DVD проигрывателей. Записывается в формате 48000Hz 16 Bit Stereo с постоянным битрейтом 1536 кБит/с.
    • MPEG1 Layer-2. Сжатый поток по стандарту ISO/IEC13818-3. Кодируется с частотой дискретизации 48000Hz. MPEG1 Layer-2 получил широкое распространение и является основным форматом для MPEG2 потоков, однако некоторыми стационарными DVD не поддерживается. Также некоторые программы DVD-авторинга требуют для формирования DVD проекта формат Dolby Digital Consumer (DDC) AC3.
    • Dolby AC3. Стандарт де-факто для DVD-Video дисков. Данный формат разработан, запатентован и является собственностью компании Dolby Laboratories Inc. Изначально формат AC3 поддерживает от одного до шести независимых каналов звука. Аппаратный энкодер ТВ тюнера кодирует 2-х канальный AC3 с частотой дискретизации 48000Hz. Данный формат доступен только на ТВ тюнере Behold TV M6 Extra. В случае, если планируется последующая запись файлов на DVD диск, настоятельно рекомендуется выбирать формат AC3. Для возможности проигрывания MPEG2 роликов с AC3 звуком на компьютере, во время установки приложения необходимо выбрать пункт "AC3 фильтр".
  • Аудио битрейт - Позволяет задать битрейт аудио потока для форматов MPEG1 Layer-2 и Dolby AC3. Доступны два значения - 256 кБит/с и 384 кБит/с. Для большинства случаев будет достаточно качества кодирования при битрейте 256 кБит/с.
  • Параметры MPEG2 энкодера - По данной команде доступен диалог для более полной конфигурации энкодера:

  • Video bitrate - Скорость записи потока видеоданных в файл. Чем выше битрейт, тем выше качество изображения при большем размере конечного файла. Битрейт может быть как постоянным (CBR), так и переменным (VBR). Постоянный битрейт используется в тех случаях, когда необходимо получить чётко заданную, постоянную скорость потока данных, например, для использования в системах передачи данных. В сложных, насыщенных мелкими деталями или динамичных сценах битрейт сохраняется постоянным за счёт ухудшения качества изображения. Чтобы этого не происходило, при сжатии видеоданных может быть использован переменный битрейт, который будет динамически увеличиваться на сложных сценах, сохраняя постоянным качество изображения.
  • Bitrate mode
    • Constant (CBR) - скорость видеопотока является постоянной величиной, которая задаётся настройкой Bitrate.
    • Variable (VBR average) - значение битрейта может изменяться в диапазоне, установленном Bitrate +/- 40% от Bitrate.
    • Variable (VBR peak) - в процессе записи битрейт будет изменяться от базового Bitrate, строго в пределах пикового значения Bitrate peak.

    Если записанный файл в дальнейшем планируется использовать для подготовки DVD и просмотра на стационарном проигрывателе, то не рекомендуется устанавливать пиковый битрейт больше 9200, т.к. некоторые стационарные проигрыватели не справляются с декодированием высоких битрейтов. Также в стандарте MPEG2 DVD заложен максимальный битрейт = 9600 при максимальном MuxRate = 10080. Рекомендуемые значения битрейта - Bitrate (kBit/s) = 6500, Bitrate peak (kBit/s) = 9000.

  • Video GOP structure - Структура видеоданных MPEG потока включает в себя последовательности так называемых групповых кадров (Group of Pictures - GOP) - структур, которые, в свою очередь, состоят из последовательности кадров разного типа (I, P, B). Каждый кадр в структуре GOP кодируется (сжимается) в соответствии с определёнными правилами. Первый кадр в структуре GOP как правило I-кадр (Intracoded), который сжимается без учёта содержимого соседних (предыдущего и последующего) кадров. P-кадры (Predicted - кодирование с предсказанием) кодируются с учётом предыдущего I или такого же P кадра. B-кадры кодируются с учётом двунаправленного (Bidirectional) предсказания на основе информации в предыдущих и последующих I или P кадрах.
    • GOP size - устанавливает общую длину последовательности GOP.
    • SubGOP - определяет периодичность расположения P и B кадров в структуре GOP. При SubGOP = 1 вся последовательность кадров, за исключением первого I-кадра, будет состоять из P-кадров.

    Рекомендуемое значение GOP (Recommended GOP) будет меняться в зависимости ос установленного битрейта (Bitrate (kBit/s). При кодировании, взаимосвязь может учитываться как между кадрами только одной GOP, так и между кадрами из соседних групп. Во втором случае последовательность GOP начинается не с I, а с B-кадра. Такая последовательность обеспечивает более высокое качество кодирования и называется открытой, т.к. данные из неё используются для кодирования B-кадра в начале следующей группы. Открытая последовательность считается нередактируемой (Non-editable GOP). Если установить флаг Force close GOP, энкодер будет ставить метки "Closed" на открытые последовательности, а B-кадры будут рассчитываться в обратном порядке (Backward predicted closed GOP). Последовательности GOP, которые изначально закрыты, всегда начинаются с I-кадров (Real closed GOP) и флаг Force close GOP не оказывает на них никакого влияния.

  • Static denoise - Метод уменьшения шума, основанный на анализе отдельно взятого кадра видеоряда.
    • Off - Cтатическое шумоподавление не используется.
    • Median - Aлгоритм, эффективно устраняющий ярко выраженные пиковые шумы, сохраняя при этом резкость отдельных яркостных и тоновых переходов.
    • Average - Aлгоритм, основанный на использование фильтра нижних частот. Значение Denoise устанавливает частоту среза фильтра. При большом значении среза, снижается четкость.
  • Motion compensated denoise - Метод уменьшения шума, основанный на анализе последовательности кадров видеоряда с использованием векторов движения. Этот метод даёт наилучшее качество без снижения резкости изображения в целом, однако, при больших значениях коэффициента Denoise возможно появление артефактов в виде "горячего воздуха".
    • Denoise - устанавливает коэффициент для определения наличия шума по вектору движения. Рекомендуемое значение 6...8.
  • Multiplexer settings - Параметры ISO/IEC13818-1 (MPEG2 Program Stream) мультиплексора.
    • SCR clock - System Clock Reference - базовые временные метки в MPEG-потоке:
      • Locked to video - тактовый генератор SCR привязывается к скорости потока кодируемого видео. Этот режим рекомендуется выбирать при прямой записи видео в файл, т.к. он обеспечивает максимально эффективную синхронизацию видео и аудио потоков.
      • Fixed clock - рекомендуется для просмотра кодированного видео налету через программный декодер. В этом случае, если теряется синхронизация видео (пропадает сигнал), не будет заметных подтормаживаний изображения.
    • NAV PACK time slots - Настройка, позволяющая при записи резервировать в MPEG потоке некоторое количество временных слотов для использования в дальнейшем навигационными пакетами (NAV PACK). Навигационные пакеты применяются для доступа к данным DVD. Минимальная единица данных DVD потока называется VOBU и содержит от 0.4 до 1.2 сек видео. В зависимости от длины GOP размер VOBU составляет от 1 до 4 GOP. NAV PACK записывается перед началом каждого VOBU и используются при подготовке DVD для указания ссылок.
    • Program end code - указывает, записывать в файл (в соответствии с ISO/IEC 13818-1) или нет код окончания потока (00 00 01 B9).
  • Quantizer matrix - В процессе MPEG кодирования кадр разбивается на блоки размером 8х8 пикселов и каждый блок подвергается дискретному косинусному преобразованию (DCT), в результате чего формируется массив данных 8х8 значений, представляющий собой матрицу коэффициентов DCT. Величина и положение коэффициентов в матрице определяют частотные характеристики исходного изображения. Коэффициенты ближе к правому нижнему углу матрицы характеризуют количество, чёткость и прорисовку мелких деталей изображения. Коэффициенты ближе к левому верхнему углу матрицы отвечают за то, как будут выглядеть крупные элементы сцены. Самый крайний коэффициент в левом верхнем углу определяет среднюю яркость квадрата 8х8 пикселов. Имея матрицу коэффициентов DCT можно восстановить исходное изображение (квадрат 8х8 пикселов). Если мелкие детали полностью отсутствуют в изображении, то значения коэффициентов в правом нижнем углу матрицы будет близко к нулю. Этими значениями можно пренебречь, полностью их обнулив. Чем больше в матрице будет одинаковых коэффициентов (например, нулей) тем сильнее её можно сжать. Значения других коэффициенты DCT так же можно подкорректировать, установив тем самым компромисс между качеством изображения и степенью его сжатия (размером файла). Процесс нормирования и коррекции коэффициентов DCT называется квантованием. Во сколько раз будет уменьшен тот или иной коэффициент DCT определяется матрицей квантования. Каждый элемент матрицы квантования является делителем для коэффициента, находящегося в той же позиции в матрице DCT. Размер коэффициента-делителя может иметь значение от 8 до 255. В силу разных требований, предъявляемых к качеству I, B и P кадров для их квантования используются две разные матрицы.
    • Matrix for intra block - матрица коэффициентов для квантования I фреймов.
    • Matrix for inter block - матрица коэффициентов для квантования B и P фреймов. Коэффициенты этой матрицы имеют, как правило, большие значения (большие коэффициенты деления) и не так частотно зависимы.
    • Select quantizer matrix - предустановленный набор матриц квантования:
      • MPEG standard - значение коэффициентов матриц устанавливаются стандартом MPEG. Так как матрицы являются стандартными, значения их коэффициентов не записываются в MPEG-файл и при его проигрывании подставляются декодером по умолчанию автоматически.
      • Low interframe compression, Philips default и High interframe compression матрицы отличаются от MPEG standard только матрицей для квантования B и P кадров (интер-блоков). В порядке перечисления эти матрицы обеспечивают более высокую компрессию B и P кадров.
      • CG/Animation - матрица квантования I-кадров отличается от стандартной равномерностью распределения коэффициентов во всей области частот. Используется для сжатия контента в виде анимации или компьютерной графики.
      • User defined - матрица квантования, определяемая пользователем. Коэффициенты матрицы редактируются непосредственно в её ячейках. По стандарту значение коэффициента в позиции (0, 0) изменению не подлежит и всегда должно оставаться равным 8. Значения матриц квантования сохраняются в пресетах для записи.
  • DCT block - Полученные после квантования коэффициенты матрицы DCT дополнительно сжимаются с помощью алгоритма RLE . Этим методом наиболее плотно упаковываются числовые ряды с периодически повторяющимися последовательностями одинаковых чисел. Матрица коэффициентов DCT после квантования как раз представляет собой массив таких чисел, значения которых убывают, заканчиваясь серией нулей, если просматривать матрицу начиная с левого верхнего угла к нижнему, двигаясь по диагонали (зигзагом). Для чересстрочных (интерлейсных) кадров более эффективным является несколько модифицированный метод альтернативного сканирования. Block scan order - указывает метод сканирования матрицы коэффициентов DCT:
    • Alternate (interlace) - рекомендуется использовать при сжатии интерлейсного видео (студийные программы, сериалы и пр.).
    • Zigzag (progressive) - рекомендуется использовать при сжатии прогрессивного видео (мультфильмы, старые фильмы). Также метод Zigzag принудительно включается при установке размера кадра как 352x288 (352x240).
  • B-frames weighting factor - Дополнительный весовой коэффициент, который усиливает квантование B кадров, уменьшая тем самым битрейт при сжатии B-кадров. При общем низком битрейте потока (CBR 3000) увеличение этого коэффициента, например до 32, позволяет улучшить качество изображения за счёт перераспределения битрейта между I и B-кадрами. Если используется только IP последовательность GOP, то при квантовании весовой коэффициент применяется для каждого второй P-кадра, которые, в данном случае, выступают в качестве виртуальных B-кадров.

Microsoft WMV - Способ записи, либо вещания видео/аудио в новом формате Microsoft Windows Media в составе контейнера ASF, который, в свою очередь, является продолжением развития контейнера AVI. Контейнер ASF имеет дополнительные функции по синхронизации аудио/видео потоков. Файл в контейнере ASF, в котором видео поток сжат кодеком Windows Media Video, обычно имеет расширение ".wmv". Формат Windows Media Video представляет собой продолжение развития Microsoft MPEG4. Формат Windows Media Audio разработан как достойный конкурент формата MPEG Layer-3 и в некоторых случаях превосходит MPEG Layer-3 по соотношению качество/размер файла.

Для кодирования файлов в формате Windows Media, а также трансляции (вещания) потока Windows Media в IP сеть, требуется OS Windows XP SP2 и выше, либо установленный апдейт Microsoft Windows Media Format Runtime версии 9 или выше. Для записи, а также трансляции потока в формате WMV доступны следующие настройки:

  • Размер кадра - Разрешение видеокадра при записи. Рекомендации см. выше.
  • Кадр/сек - см. выше.
  • Аспект - Соотношение сторон кадра при проигрывании WMV файлов. Данное соотношение считывается проигрывателем для установки требуемого соотношения сторон кадра при выводе изображения.
  • Сжатие видео потока - Выбор доступного WMV кодека, а также настройка основных параметров кодека.
  • Формат/сжатие аудио потока - Выбор доступного WMA кодека, а также настройка основных параметров кодека.
  • Использовать предбуферизацию при записи - Данная опция рекомендуется при итоговых битрейтах > 1500Кбит/с. ASF мультиплексор при этом использует доступную оперативную память и формирует поток в памяти большими блоками, затем данные блоки записывает в файл. Иначе поток формируется малыми блоками.
  • Мой титул - Использовать пользовательский титул в описании медиа файла.

Конфигурация WMV кодека:

  • Кодек WMV - Выбор WMV кодека. Содержимое данного списка зависит от версии установленного апдейта Microsoft Windows Media Format Runtime. Для систем с частотой CPU >= 2000Mhz рекомендуется кодек "Windows Media Video 9". Для систем с частотой CPU < 2000Mhz, рекомендуется кодек "Windows Media Video V8".
  • Формат WMV кодека - Базовая конфигурация выбранного кодека
    • Постоянный битрейт, переменное качество (CBR) - Режим кодирования с постоянным битрейтом. Рекомендуется.
      • Битрейт (Кбит/с) - Задает базовый битрейт для видеопотока. Чем выше битрейт, тем выше качество кодирования, однако полученный размер файла будет соответственно больше. Для записи полного кадра 768x576 рекомендуется битрейт не ниже 1200 Кбит/с.
      • Резкость (%) - Данный параметр определяет взвешенное качество изображения при заданном битрейте. Не рекомендуется устанавливать "Резкость" выше 85%, иначе возможны пропуски кадров WMV кодеком , даже при небольшой загрузке CPU. Также не рекомендуется устанавливать "Резкость" выше 50% при низких битрейтах (< 500 Кбит/с), иначе будут пропуски кадров. Параметр "Резкость" не влияет на загрузку CPU.
    • Переменный битрейт, постоянное качество (VBR Quality) - Режим кодирования с переменным битрейтом на основе показателя качества. Данный режим поддерживают не все WMV кодеки. Если кодек не поддерживает VBR Quality, выбор этого режима будет недоступен.
      • Качество (%) - Задает базовый уровень качества для режима кодирования VBR Quality. Чем выше качество, тем выше итоговый битрейт.
  • Ключевой кадр (с) - Задает интервал ключевых кадров в потоке. Чем больше интервал, тем меньше битрейта потратит кодек на кодирование разности информации между ключевыми кадрами, однако, если видео контент имеет много быстросменяемых динамических сцен, то качество сжатия получится низким. Общие рекомендации следующие - для видео контента с малым количеством динамических сцен, интервал 4-6с, иначе 3-4с.
  • Сложность - Каждый WMV кодек имеет свой диапазон регулировки сложности кодирования. Сложность кодирования определяет итоговое качество изображения. Чем выше сложность, тем выше качество, однако при этом нелинейно возрастает загрузка CPU. Для потока реального времени предназначен уровень сложности кодирования, отмеченный как Live и ниже. Все уровни сложности выше Live требуют мощнейший CPU (которого пока не существует) и поэтому они определены Microsoft для перекодирования файлов (Offline контента). Для потока реального времени они пригодны лишь для кодирования малых фреймов (например 160x120).
  • Операция с видеополями - WMV кодек имеет встроенный механизм деинтерлейсинга, который можно применять перед кодированием. Если входящее видео является прогрессивным, либо есть желание использовать другие методы деинтерлесинга на основе подключаемых плагинов, нужно выбрать в списке "Не выполнять (кодирование как есть)". Также кодек "Windows Media Video 9 Advanced Profile" из апдейта Microsoft Windows Media Format Runtime 9.5 и 11 поддерживает режим раздельного кодирования интерлейсных полей. Данный режим довольно требователен к ресурсам CPU и предназначен в основном для воспроизведения и вывода записанного контента на интерлейсных устройствах (например телевизоре). При раздельном кодировании полей, требуется немногим более высокий битрейт.

Конфигурация WMA кодека:

  • Кодек WMA - Выбор WMA кодека. Содержимое данного списка зависит от версии установленного апдейта Microsoft Windows Media Format Runtime.
  • Формат WMA кодека - Основная конфигурация выбранного кодека
    • Постоянный битрейт, переменное качество (CBR) - Режим кодирования с постоянным битрейтом. Рекомендуется. Для записи видео совместно с аудио, в данном списке доступны форматы отмеченные аббревиатурой (A/V). Для качественного кодирования аудио желательно выбирать форматы с битрейтом не ниже 128 Кбит/с.
    • Переменный битрейт, постоянное качество (VBR Quality) - Режим кодирования с переменным битрейтом на основе показателя качества. Данный режим поддерживают не все WMA кодеки. Если кодек не поддерживает VBR Quality, выбор этого режима будет недоступен.

Примечание:
Ядро Windows Media Format имеет функцию качественного ресемплирования аудио, поэтому при записи звука чипсетом SAA7134/35 доступны все возможные частоты дискретизации для выбранного WMA кодека. При выборе формата, например, "192 kbps, 48 kHz, stereo (A/V) CBR" для чипсета SAA7134 произойдет автоматическое конвертирование частоты дискретизации из 32кГц в 48кГц без ощутимой потери качества. Для чипсета SAA7135 также будет выбираться ближайшая поддерживаемая частота дискретизации, которая при необходимости будет автоматически ресемплирована в конечное значение. Форматы, требующие ресемплирования или конвертирования исходного PCM потока будут подсвечиваться в списке другим цветом.

Microsoft ASF - Способ записи, либо вещания видео/аудио в составе контейнера ASF, посредством кодирования видео и аудио потоков сторонними кодеками (не Windows Media). Контейнер ASF является продолжением развития контейнера AVI и имеет дополнительные функции по синхронизации аудио/видео потоков.

Для кодирования файлов в формате ASF, а также трансляции (вещания) потока ASF в IP сеть, требуется OS Windows XP SP2 и выше, либо установленный апдейт Microsoft Windows Media Format Runtime версии 9 или выше. Для записи, а также трансляции потока в формате ASF доступны следующие настройки:

  • Размер кадра - Разрешение видеокадра при записи. Рекомендации см. выше.
  • Формат - см. выше.
  • Кадр/сек - см. выше.
  • Сжатие видеопотока - Позволяет выбрать для сжатия видео любой зарегистрированный в системе VCM или DirectShow видео кодек. Рекомендации см. выше.
  • Формат/сжатие аудио потока - Выбор формата и тип сжатия для аудио потока. При установленной галочке "Запись звука чипсетом SAA7134/35 через PCI", список доступных форматов без применения конвертации будет ограничен частотами 32/44.1/48кГц для чипсета SAA7135 и 32кГц для чипсета SAA7134.
  • Использовать предбуферизацию при записи - см. выше.
  • Мой титул - см. выше.

Общие настройки для видео+аудио записи:

  • Останавливать запись при отсутствии сигнала - При пропадании синхросигнала видео (например перерыв в программе телепередач), запись автоматически остановится, записав данное событие в лог - файл.
  • Высокий приоритет процесса при записи - Программа будет устанавливать высокий приоритет своего процесса во время записи видео. При высоком приоритете меньше вероятность пропуска кадров.
  • Запись в файл - Направлять конечный поток на запись в файл:
    • Путь для записываемых файлов - Выбор папки для расположения файлов видеозаписей. Внимание!. Путь для записываемых файлов не сохраняется в пресетах.
    • Шаблон имени файла - Шаблон имени файла может включать в себя любой набор допустимых в именах файлов символов, а также макросы, вместо которых в имя файла будут подставляться дата, время, название канала, имя TV-программы и др. предопределённые макросами элементы. Шаблон должен содержать только имя файла БЕЗ указания пути и БЕЗ расширения. Для удобства ввода макросов можно вызвать диалог-подсказку, с помощью которого можно сформировать нужный шаблон.
    • Лог - При запуске записи, программа будет создавать лог-файл (*.log) в который будет записываться дополнительная информация в процессе записи. Лог-файл призван помочь выявить различного рода проблемы при записи. Также в лог-файле отображается информация о параметрах текущей записи. Лог-файл можно открыть в любом текстовом редакторе.
    • Разрешить перезапись существующего файла - При снятой галочке, в случае если текущее имя файла, сгенерированное программой совпадет с уже существующим файлом, программа дополнительно подставит несколько символов для того чтобы избежать перезаписи и потери существующего файла.
    • Разбивать файлы по - Разбивать файл при записи на сегменты заданного размера.
  • Вещание в IP сеть - Направлять конечный поток в IP сеть. В зависимости от способа записи доступны режимы вещания HTTP Unicast и UDP Multicast:
    • HTTP Unicast - Режим трансляции в IP сеть по протоколу HTTP. В данном режиме создается пассивный сокет, который ожидает подключения клиентов. При поступлении запроса от клиента, выполняются условия проверки и при положительном результате устанавливается соединение, сокет переходит в активный режим и начинает передавать клиенту поток. Каждому подключенному клиенту последовательно отправляется отдельная копия каждого пакета. При большом количестве подключенных клиентов может не хватить пропускной способности сети.
      • Порт - Сетевой порт сокета для вещания потока Windows Media. При указании 0, будет автоматически назначен свободный порт. Номер порта нужно знать клиенту при подключении. Готовую URL строку для подключения клиента можно получить, как показано здесь. Внимание! Если выбранный порт закрыт в целях безопасности вашим провайдером, либо администратором сети, подключение клиентов будет невозможно. Необходимо выбрать другой доступный порт.
      • Клиенты - Максимальное разрешенное число клиентов для подключения. Максимум - 50. Необходимо помнить, что Windows 2000 Prof и Windows XP являются рабочими станциями и не могут иметь больше 10 подключений. Для снятия этого ограничения требуется OS Windows 2000 Server (Advanced Server) или Windows 2003 Server.
      • Настройка ограничения доступа клиентов - Вызывает ACL лист для администрирования подключения клиентов. По умолчанию ACL лист пуст и подключение разрешено с любого хоста. При желании можно внести ограничения на подключение. После внесения изменений в ACL лист, достаточно его сохранить и заново запустить вещание. Внимание!. ACL лист не сохраняется в пресетах.
    • UDP Multicast - Режим трансляции в IP сеть посредством групповой адресации по протоколу UDP. В данном режиме создается датаграммный сокет, который отправляет датаграммы в виртуальную Multicast группу. Если клиент вошел в данную группу, то данному клиенту маршрутизатор доставит копию пакета. Каждому клиенту будет отправлена одна и та же копия пакета. Данный режим экономит пропускную способность сети, однако имеет некоторые особенности:
      • IP адрес группы - Указать IP адрес класса D (диапазон 224.0.0.1 - 239.255.255.254), который определяет Multicast группу. Данный адрес указывается на клиенте при открытии UDP потока.
      • Порт - Указать сетевой порт сокета для для посылки Multicast сообщений. Данный порт указывается на клиенте при открытии UDP потока.
      • Сетевой интерфейс - Указать локальный сетевой интерфейс, который сокет будет использовать для посылки Multicast сообщений. Если интерфейс выбран как "Любой (авто)", сокет самостоятельно найдет сетевой интерфейс, читая таблицу маршрутизации для выбора наилучшего интерфейса.
      • TTL датаграммы - Указать TTL (Time To Live) для датаграмм с групповыми сообщениями. При TTL =1, датаграмма ограничена подсетью хоста ее отославшего, и не будет обработана ни одним маршрутизатором. Такое значение подходит для трансляции потока только в одной подсети. Для того чтобы датаграмма была передана в другую подсеть, необходимо указать TTL минимум таким, на какое количество подсетей должна быть передана датаграмма. Параметр TTL зависит от IP адреса группы, который накладывает ограничения:
TTL | IP адрес группы | Ограничения
1 | 224.0.0.0 - 224.0.0.255 | Датаграмма ограничена подсетью хоста ее отославшего, и не будет обработана ни одним маршрутизатором, не зависимо от TTL.
<32 | 239.255.0.0 - 239.255.255.255 | TTL будет игнорировано выше 32
<64 | 239.192.0.0 - 239.195.255.255 | TTL будет игнорировано выше 64
<255 | 224.0.1.0 - 238.255.255.255 | Нет ограничений, глобальное использование

  • Видеообработка кадра - Настройки для обработки кадра перед сжатием. Позволяет использовать режим дополнительной видеообработки, построенной на основе подключаемых плагинов. Подключенные плагины для записи сохраняются отдельно и не пересекаются с подключенными плагинами для видеопросмотра. Подключенные плагины для записи также сохраняются в пресете.
  • Масштабирование кадра - Настройки, которые позволяют включить режим отсечения границ кадра а также изменить конечный размер кадра путем ресемплирования изображения.
  • Просмотр видео при записи в оверлее DirectDraw - Использовать вывод предпросматриваемого видео во время записи в DirectDraw Overlay Surface в формате YUY2. Это предотвращает повышение загрузки CPU при перекрытии видеоокна другими окнами, либо скрытии видеоокна. Также это даст возможность при использовании записи в формате RGB24 выводить видео на просмотр в оверлей, что позволит дополнительно снизить загрузку CPU во время записи. Настоятельно рекомендуется использование этой опции. Данная опция недоступна в Windows Vista.
  • Не выводить на просмотр записываемое видео - При записи не отображать просмотр видео. Это позволяет дополнительно снизить нагрузку на CPU и уменьшить вероятность пропуска кадров. Внимание!. Если встроенный планировщик вызывает подошедшее по времени задание на запись видео и при этом программа была свернута в системный трей (находилась в режиме ожидания), то наличие просмотра при записи будет зависеть от опции Блокировать поток просмотра при старте записи из трея.

  • Запись звука чипсетом SAA7134/35 через PCI - Эта опция разрешает оцифровку и запись звука чипсетом SAA7134 или SAA7135 вместо звуковой карты. При использовании записи звука чипсетом сильно уменьшается вероятность рассинхронизации аудио и видеопотока в конечном файле. Внимание!. Если используется функция общего вывода звука чипсетом по шине PCI (см. окно "Настройки", закладка "Аудио") и звуковой кабель не подключен к звуковой карте, то в этом случае данная опция должна быть обязательно включена, иначе в записанном файле будет тишина. Данная опция накладывает ограничение - чипсет SAA7135 поддерживает частоты дискретизации только 32/44.1/48 кГц, SAA7134 - только 32 кГц. При выборе аудиоформатов, имеющих отличные от этих частоты дискретизации, будет выполнено программное ресемплирование PCM потока до нужных частот, что немного снизит качество.
  • Привязка звука к частоте кадров - Включить режим автоматической подстройки звукового тактового генератора чипсета тюнера к скорости видео. Данная опция снижает вероятность рассинхронизации звука и видео при записи с некачественных видеоисточников, однако, вызывает неприятные шумовые эффекты при перестройке тактового генератора во время сбоя синхронизации видеосигнала.
  • Аудиосемплы короткой длины - По умолчанию, время прохождения аудиосемплов установлено равным 500мс. Это создает трудности синхронизации при использовании паузы, аудиопотока с видеопотоком, у которого время прохождения видеосемплов равное 40мс для PAL/SECAM и 33мс для NTSC. Данная опция уменьшает время прохождения аудиосемплов до нескольких заданных значений. По умолчанию используется время, равное 40мс (1 кадр PAL). Это позволяет корректно работать с паузой. Если вы пользуетесь паузой при захвате, данная опция должна быть обязательно включена. Если пауза не используется, то опцию можно выключить.
  • Задержка аудио потока (мс) - Установить стартовую задержку аудио потока относительно видео. При записи аудио потока звуковой картой, в большинстве случаев, аудио поток стартует раньше видео потока на величину 100-200 мс. Данной опцией можно подрегулировать начальную синхронизацию потоков.
  • Не записывать звуковую дорожку - Выполнять запись/трансляцию без звука.

Видеообработка кадра (режим записи):

Данное окно предназначено для настройки видеообработки изображения при записи. Видеообработка реализована методом подключаемых дополнительных модулей - плагинов. Если запись осуществляется с использованием аппаратного MPEG энкодера, то программная видеообработка изображения (программное шумоподавление, повышение чёткости, гамма-корекция и пр.) в этом случае невозможна. Однако, при аппаратной записи плагины могут контролировать параллельный видеопоток, выводимый для просмотра и, тем самым, управлять процессом записи. Таким образом, такие плагины, как Детектор логотипов и Детектор движения будут выполнять свои функции и в нужные моменты времени включать, останавливать и ставить запись на паузу.

  • Используемые фильтры процессинга - Список подключаемых плагинов для видеообработки и/или наложения всевозможных эффектов. В зависимости от подключенных плагинов можно менять их последовательность выполнения. Также можно временно деактивировать плагин, путем снятия с него флажка. Во время записи, окно настройки видеообработки будет доступно, при этом можно менять настройки подключенных плагинов прямо во время записи. Внимание! Если запись в текущий момент неактивна, то настройки плагинов процессинга будут недоступны, так как плагины находятся в offline режиме. Для того чтобы настроить каждый плагин, а также увидеть его реальную работу, нужно нажать кнопку "Тест". При этом все плагины из списка автоматически подключаются на текущий просмотр и можно визуально оценить их работу, а также настроить их.
  • Используемый фильтр деинтерлейсинга - Выбор доступного плагина деинтерлейсинга. Выбрать можно лишь один плагин, который будет заниматься деинтерлейсингом. Деинтерлейсинг работает только при выводе обоих видеополей кадра, т.е. когда высота кадра выбрана как 576 для PAL/SECAM (например 768x576) или 480 для NTSC (например 720x480).
  • Поменять порядок следования видеополей - Многие кодеки поддерживают интерлейсную обработку кадра (расшивают кадр на поля и обрабатываю поля раздельно). Например DV кодеки и некоторые MPEG кодеки. Для таких кодеков нужно правильно указать порядок следования полей. При неправильном порядке полей, изображение выводимое на интерлейсное устройство визуализации (например телевизор) будет характерно подергиваться при движении сцены по горизонтали. В большинстве случаев требуется следующий порядок полей: PAL/SECAM - Top Field First, NTSC - Bottom Field First. Чипсет SAA713x выдает в YUV форматах всегда порядок Bottom Field First, в RGB форматах - Top Field First. Данная опция позволяет определить нужный порядок следования полей при записи в интерлейсном режиме. При использовании любого алгоритма деинтерлейсинга, данная настройка теряет силу, так как деинтерлейсинг превращает интерлейсный кадр в прогрессивный, смешивая поля.
  • Форсирование буферизации видео в памяти (кадров) - Указать количество кадров, которое будет буферизировать DirectShow конвейер во время записи. Данная настройка позволяет свести на нет потерю кадров во время записи, вызванных кратковременными дисковыми коллизиями, либо кратковременными пиковыми загрузками CPU. При отключении данной опции, будет использоваться буферизация WDM драйвера по умолчанию. WDM драйвер 3.0.0.0 и выше, буферизирует по умолчанию 18-25 кадров.
    Рекомендуется использовать буферизацию видео, глубиной не меньше 1 секунды (25 кадров). 1 секунда буферизации для потока 768x576 YUY2 отнимет ~22МБ несвопируемой ( Nonpaged pool) оперативной памяти во время записи. Не рекомендуется использовать буферизацию видео больше чем 50 кадров, это может привести к расходу несвопируемой памяти и вызвать коллизию Windows в попытке освободить ресурсы. Предлагаем небольшую таблицу рекомендуемых значений буферизации, в зависимости от объема оперативной памяти:

    RAM

    Буферизация видео

    128 МБ | 18 кадров
    256 МБ | 25 кадров
    384 МБ | 32 кадра
    >=512 МБ | 40 кадров

Масштабирование кадра:

Данное окно предназначено для настройки выходной геометрии кадра, которая будет формироваться после видеообработки и непосредственно перед сжатием. При записи с использованием аппаратного MPEG энкодера это окно недоступно.

  • Отсечение краев кадра - Задать параметры отсечения краев кадра, для устранения нежелательных артефактов, которые иногда возникают по краям изображения.
  • Масштабирование кадра - Изменить конечный размер изображения путем ресемплирования изображения. Также можно выбрать подходящий метод ресемплирования. Масштабирование кадра - достаточно ресурсоемкая процедура и значительно увеличивает загрузку CPU. Необходимо помнить, что для качественного масштабирования интерлейсного кадра необходимо сначала выполнить деинтерлейс, иначе артефакты после ресемплирования интерлейса в дальнейшем устранить будет невозможно.

Так как при отсечении краёв и/или масштабировании кадра, выходные размеры кадра будут меняться, то, как и при выборе начального размера кадра, необходимо следить за тем, чтобы его геометрические размеры оставались кратными 8 или 4. Разобраться с кратностью этим цифрам поможет подсветка выходных значений размера кадра определённым цветом. Если цифра не кратна даже 4, то подсветка будет красным цветом, если цифра кратна 4, но не кратна 8, то подсветка будет жёлтым. Идеальным вариантом является ситуация, когда размеры кадра кратны 8 по ширине и 4 по высоте (цифры не подсвечены). В этом случае никогда не возникнет проблем с геометрией кадра при использовании различных кодеков. При не кратности 4 могут возникнуть проблемы при записи а также при воспроизведении записанного файла, вплоть до возникновения критических ошибок.

Примечание:
Для борьбы только с краевыми артефактами лучше всего использовать плагин видеобработки "Заливка бордюров", без использования отсечения.

Закладка настроек аудио записи:

  • Пресеты для аудио записи - Список заготовленных пресетов для аудио записи, в которых находится заранее настроенная конфигурация. См. выше описание пресетов для видео/аудио записи.
  • Способ аудиозаписи - Формат записи аудио. Поддерживаются несколько способов - "Microsoft ACM", "Microsoft ACM через DirectShow", "Microsoft ASF", "Microsoft WMA", "Software MPEG Audio" и "Hardware MPEG Audio". Для того чтобы была возможность записывать в формате "Software MPEG Audio", необходимо установить InterVideo WinDVD Creator со второго диска, прилагаемого к ТВ тюнеру. Для того чтобы была возможность записывать в форматах "Microsoft ASF", "Microsoft WMA", требуется Windows XP SP2 и выше, либо установленный апдейт Microsoft Windows Media Format Runtime версии 9 или выше. Способ аудиозаписи "Hardware MPEG Audio" доступен только на ТВ тюнерах с аппаратным энкодером. Каждый способ записи имеет собственные настройки:

Microsoft ACM и Microsoft ACM через DirectShow - Способ записи аудио в WAV формат. Способ "Microsoft ACM" не поддерживает запись звука чипсетом SAA7134/35 по шине PCI. Рекомендуется его использовать при записи через звуковую карту. Способ "Microsoft ACM через DirectShow" поддерживает запись как звуковой картой, так и чипсетом SAA7134/35 по шине PCI.

  • Формат/сжатие аудио - Выбор доступного ACM аудиокодека, из списка установленных в системе аудиокодеков, а также формата, свойственного выбранному кодеку. При установленной галочке "Запись звука чипсетом SAA7134/35 через PCI", список доступных форматов без применения конвертации будет ограничен частотами 32/44.1/48кГц для чипсета SAA7135 и 32кГц для чипсета SAA7134.
  • Не формировать WAV контейнер для MP3 - При использовании аудиокодека MPEG Layer-3, программа будет формировать звуковой файл без RIFF заголовка и с расширением *.mp3. Такая структура файла свойственна для формата MP3 и большинство аудиоплейеров воспринимают именно такие файлы.

Software MPEG Audio (InterVideo) - Способ записи аудио в MPEG1 Layer II формат. Данный формат используется в стандартах MPEG1/2, а также позволяет записывать только аудио поток и достаточно качественно кодирует звук с невысоким битрейтом.

  • Аудио битрейт - Определяет скорость записи аудиопотока в файл. Чем выше битрейт, тем выше качество звука. Оптимальный битрейт - 224kBit/s.
  • Частота (Гц) - Частота выборки аудиосемплов при аналого-цифровом преобразовании (АЦП).
  • Кодирование - Режим кодирования аудиоканалов. Рекомендуемые режимы Stereo и Joint Stereo.
  • Режим мультиплексора - Формат представления MPEG потока:
    • Elementary Stream - Чистый поток, состоящий из звуковых фреймов без инкапсуляции в PS паки. Файл будет иметь расширение .mpa. Рекомендуется.
    • Program Stream - Звуковые фреймы инкапсулированы в PS паки формата ISO/IEC13818-1. Файл будет иметь расширение .mpg.

Hardware MPEG Audio - Способ записи звука в MPEG формат, используя аппаратный энкодер. Доступен только для ТВ тюнеров с аппаратным MPEG энкодером на борту.

  • Аудио формат - Выбор формата аудио потока для кодирования. Доступны форматы MPEG1 Layer-2 и Dolby AC3. Формат Dolby AC3 доступен только на ТВ тюнере Behold TV M6 Extra.
  • Аудио битрейт - Определяет скорость записи аудиопотока в файл. Чем выше битрейт, тем выше качество звука.
  • Режим мультиплексора - Формат представления MPEG потока:
    • Elementary Stream - Чистый поток, состоящий из звуковых фреймов без инкапсуляции в PS паки. Файл будет иметь расширение .mpa либо .ac3. Рекомендуется.
    • Program Stream - Звуковые фреймы инкапсулированы в PS паки формата ISO/IEC13818-1. Файл будет иметь расширение .mpg.

Microsoft WMA - Способ записи, либо вещания аудио в новом формате Microsoft Windows Media в составе контейнера ASF. Файл в контейнере ASF, содержащий только аудиопоток сжатый кодером Windows Media Audio, обычно имеет расширение ".wma". Формат Windows Media Audio разработан как достойный конкурент формата MPEG Layer-3 и в некоторых случаях превосходит MPEG Layer-3 по соотношению качество/размер файла.

Для кодирования файлов в формате Windows Media, а также трансляции (вещания) потока Windows Media в IP сеть, требуется OS Windows XP SP2 и выше, либо установленный апдейт Microsoft Windows Media Format Runtime версии 9 или выше. Для записи в формате WMA доступны следующие настройки:

  • Формат/сжатие аудио - Выбор доступного WMA кодека, а также настройка основных параметров кодека. Описание параметров WMA кодека см. выше.
  • Мой титул - см. выше.

Microsoft ASF - Способ записи, либо вещания аудио в составе контейнера ASF посредством кодирования аудио потока сторонними ACM кодеками (не Windows Media).

Для записи файлов в формате ASF, а также трансляции (вещания) ASF потока в IP сеть, требуется OS Windows XP SP2 и выше, либо установленный апдейт Microsoft Windows Media Format Runtime версии 9 или выше. Для записи в формате ASF доступны следующие настройки:

  • Формат/сжатие аудио - Выбор доступного ACM аудиокодека, из списка установленных в системе аудиокодеков, а также формата, свойственного выбранному кодеку. При установленной галочке "Запись звука чипсетом SAA7134/35 через PCI", список доступных форматов без применения конвертации будет ограничен частотами 32/44.1/48кГц для чипсета SAA7135 и 32кГц для чипсета SAA7134.
  • Мой титул - см. выше.

Общие настройки для аудио записи:

  • Запись звука чипсетом SAA7134/35 через PCI - Эта опция разрешает оцифровку и запись звука чипсетом SAA7134 или SAA7135 вместо звуковой карты. Внимание. Если используется функция общего вывода звука чипсетом по шине PCI (см. окно "Настройки", закладка "Аудио") и звуковой кабель не подключен к звуковой карте, то в этом случае данная опция должна быть обязательно включена, иначе в записанном файле будет тишина.
  • Отключать прослушивание во время записи - Гасить звук во время аудио записи.
  • Высокий приоритет процесса при записи - Программа будет устанавливать высокий приоритет своего процесса во время записи аудио.
  • Запись в файл - см. выше.
  • Вещание в IP сеть - см. выше.

Общие настройки звука для видео/аудио и аудио записи:

Данный диалог является общим для видео/аудио и аудио записи и настройки этого диалога не сохраняются в пресетах.

  • Устройство аудио записи - Выбор устройства записи звука при видео/аудио записи, а также при аудио записи. Выбирать нужно ту звуковую карту, на вход которой подключен аудио кабель от ТВ тюнера. Данное устройство не используется при записи звука чипсетом SAA7134/35 по шине PCI. Под Windows Vista выбор устройства записи недоступен в силу того, что устройство записи выбирается через Аудио микшер для записи.
  • Аудио микшер для записи - Настройки этой группы никак не влияют на запись звука чипсетом SAA7134/35 по шине PCI и используются только для режима записи через звуковую карту.
    • Микшер записи - Выбор системного аудиомикшера (если в системе несколько подобных устройств). Выбирайте только звуковую карту, к которой подключен ТВ тюнер. При смене микшера, меняются доступные линии для записи. Под Windows Vista выбранный микшер является также и устройством записи.
    • Активная линия записи - Выбор линии микшера для регулировки уровня записи звука. Выбирается та линия, к которой подключен звуковой кабель ТВ тюнера. Обычно это Line-In или Analog Mix.

Закладка настроек для снимка:

  • Пресеты для снимка - Список заготовленных пресетов для снимка, в которых находится заранее настроенная конфигурация. См. выше описание пресетов для видео/аудио записи.
  • Формат снимка - Выбор формата без сжатия - BMP, либо формата со сжатием - JPEG. Формат JPEG имеет регулятор качества. Чем выше качество, тем больше размер файла.
  • Текущий размер кадра - Геометрический размер видеобуфера, который используется в данный момент при выводе видеоизображения. Полученный снимок будет иметь эти геометрические размеры, в случае, если галочка "Ресемплировать в" будет выключена.
  • Ресемплировать в - Ресемплинг исходного размера кадра в заданный размер по методу Lanczos3.
  • Интервал для серии (с) - Задать интервал времени для режима "Серия снимков".
  • Вставлять название канала в имя файла - Добавлять к имени файла, состоящего из таймштампа, название текущего ТВ канала.
  • Путь для файлов снимков - Выбор папки для расположения файлов снимков. Внимание!. Путь для файлов снимков не сохраняется в пресетах.

Окно предварительного просмотра снимка имеет контекстное меню для выполнения нескольких действий.


Scheduler

Behold TV - Планировщик

Встроенный планировщик программы предназначен для запуска и выполнения заданий в соответствии с составленным расписанием. Планировщик работает только при запущенной основной программе Behold TV или при загруженной и работающей в фоновом режиме программе Behold TV Agent. После установки всех заданий программу Behold TV можно убрать в трей, где программа будет оставаться в режиме ожидания. Если программа Behold TV была запущена с ключом в командной строке -r: (запись), то задания встроенного планировщика выполняться не будут до тех пор, пока запись не будет завершена.

Задания планировщика могут быть трёх типов:

  1. Задание, активирующее тюнер в указанное время для просмотра телевизионной или прослушивания радиопрограммы - "Просмотр".
  2. Задание, запускающее режим таймшифт - "Таймшифт".
  3. Задание, выполняющее запись телевизионной или радиопрограммы - "Запись".

Для каждого типа задания выбирается режим работы тюнера (TV, FM, VHS, S-VHS) и название канала, на который переключится тюнер при его выполнении.

Для задания "Запись" дополнительно указывается режим записи (запись видео, запись только аудио, запись серии снимков), выбирается пресет с настройками для записи и шаблон имени файла. Шаблон имени файла может включать в себя любой набор допустимых в именах файлов символов, а также макросы, вместо которых в имя файла будут подставляться дата, время, название TV-канала, имя TV-программы и др. предопределённые макросами элементы. Шаблон должен содержать только имя файла БЕЗ указания пути и БЕЗ расширения.

При выборе в качестве теле/радиоканала строки <Не выбран> задание будет выполняться для текущего или активного на момент окончания работы с программой канала.
При выборе в качестве пресета для записи строки <Не выбран>, запись будет выполняться в соответствии с текущими настройками записи в "Панели записи".

Все три типа заданий имеют ограничения по времени выполнения. Максимальное время выполнения одного задания - 24 часа. Примерно за 15 сек, всплывающая подсказка оповестит о завершения задания (Win98 не поддерживает баллонных всплывающих подсказок). Время окончания, а так же выбранные по завершению задания действия, могут быть изменены непосредственно в процессе его выполнения. Для этого необходимо открыть планировщик, в настройках которого для выполняющегося текущего задания будут доступны для изменения только параметры времени окончания задания и действия после его выполнения (см. скриншот).

Время запуска и остановки задания (в меньшую и большую сторону, соответственно) может быть автоматически скорректировано на определённую величину (см. "Настройки планировщика"). Если установленное время запуска очередного задания накладывается на интервал выполнения предыдущего задания или совпадает с временем его окончания, то поправка на время остановки/запуска игнорируется или учитывается частично (расчет времени проводится по факту, на лету).

Любые задания могут быть как одноразовыми, так и периодическими, т.е. с периодом выполнения один или несколько раз в неделю. Периодические задания не имеют даты выполнения.

По окончании задания планировщик может выполнить ряд следующих действий:

  • Свернуть программу Behold TV в трей для ожидания запуска следующего задания.
  • Выйти из программы. В этом случае, для выполнения планировщиком оставшихся заданий необходимо, чтобы была запущена программа Behold TV Agent.
  • Активировать Ждущий режим Windows (Suspend).
  • Активировать Cпящий режим Windows (Hibernate). Если спящий режим отключен или не поддерживается системой, то компьютер будет переходить в ждущий режим Windows (Suspend). Внимание! Для того чтобы система корректно выходила из режима Hibernate или Suspend, необходимо, чтобы в настройках Windows -> "Панель управления" -> "Электропитание" -> "Дополнительно" был снят флажок "Запрашивать пароль при выходе из ждущего режима". В случае, если остановлена Windows-служба "Совместимость быстрого переключения пользователей", то данный флажок не будет работать и подтверждение входа не будет производиться в любом случае. Также, в режимах Hibernate и Suspend недопустимо отключение питания компьютера от сети.
  • Выключить компьютер. Внимание! В выключенном состоянии система сможет отслеживать и запускать задания планировщика только на тюнерах с технологией ARPC.

Любые изменения, внесённые в параметры задания необходимо подтверждать нажатием "Сохранить конфигурацию текущего задания".

Назначенные задания могут быть отфильтрованы по дням недели. Для этого служат закладки с названиями Пн ... Вс. Закладка, отмеченная знаком "[!]", предназначена для контроля заданий на предмет их наложения друг на друга по времени исполнения. В случае обнаружения таких заданий, они отобразятся списком, а в поле "Пересечения" будут отмечены индексы заданий, имеющие общие пересечения. Данные задания необходимо скорректировать, отключить или удалить, в противном случае, часть из них не сможет выполниться вовсе, либо выполнится частично. Имеющие перекрытия по времени запуска и выполнения задания выполняются в соответствии с установленным приоритетом:

- Запись
- Таймшифт
- Просмотр

Это означает, что просмотр может быть в любой момент прерван заданием, запускающим таймшифт или запись. Запущенный вручную или из планировщика таймшифт может быть прерван заданием, активирующим запись. Запущенный вручную или планировщиком процесс записи может быть прерван только вручную, либо остановлен самим заданием по истечении времени задания.

Из двух заданий "Просмотр" одного уровня, приоритетным является второе задание, при "Таймшифт" и "Запись" - первое. Таким образом., если имеются два задания "Запись" с перекрытием по времени выполнения, то второе задание не запустится, пока полностью не завершится первое. Точно так же, запрограммированное задание "Запись" не начнёт выполняться, если в данный момент производится запись запущенная вручную.

Прерванное задание считается отменённым. Также, задание помечается в планировщике как "Отменено", если:

  • В планировщике была нажата кнопка "Отменить". В этом случае планировщик теряет контроль над дальнейшим выполнением задания, но само запущенное действие (Запись, Таймшифт) не отменяется.
  • При исполнении задания Просмотр была запущена запись или включен Таймшифт.
  • При исполнении задания Таймшифт была нажата кнопка "Остановить Таймшифт".
  • При исполнении задания Запись, запись была остановлена вручную.
  • Программа Behold TV была закрыта во время выполнения задания.

Отменённое задание всегда можно восстановить, нажав кнопку "Восстановить" в окне планировщика. Если время выполнения задания не истекло, то отменённое действие будет перезапущено. Внимание! Для периодических заданий, диспетчер планировщика автоматически снимет статус "Отменено" и восстановит задание после истечения времени по которому текущее задание должно завершиться.

При смене и сохранении параметров задания, если задание имело статус "Отменено", то статус его не изменится. В этом случае задание нужно дополнительно восстановить нажатием кнопки "Восстановить". По истечении времени выполнения статус отменённого задания снимется автоматически.

Если задание имеет статус "Отключено", оно никогда не выполнится, а также не будет использовано при проверке пересечений.

Выполненное, а также истекшее по времени завершения одноразовое задание помечается в списке планировщика как устаревшее. Периодические задания с недельным циклом устаревшими быть не могут.

Планировщик может запускать задание, если до времени его окончания осталось больше 30 сек. Это означает, что планировщик не пропустит задание, даже если время его запуска уже прошло.

Внимание! Если до запуска задания был вручную установлен таймер на отключение, то любое задание планировщика при старте задания аннулирует таймер. Повторная ручная установка таймера на отключение активирует его. Если таймер на отключения сработает быстрее, чем закончится задание, данное задание отменится. Если открыть окно планировщика и сохранить параметры выполняющегося задания, то таймер на отключение снова будет аннулирован.

Планировщик имеет свои собственные настройки, доступ к которым можно получить, кликнув по иконке "Настройки планировщика":

  • Авто-поправка времени запуска и завершения задания (-/+ мин) - Указывает планировщику на необходимость запускать задание раньше и останавливать его позже назначенного времени.
  • Перезаписывать существующий файл при выполнении задания - Если создаваемый планировщиком файл уже существует на диске, то этот файл будет перезаписан. В противном случае к имени нового файла будет добавлено сквозное число . Чтобы исключить появление файлов с одинаковыми именами, в шаблоне имени файла необходимо использовать макросы времени.
  • Выводить диалог уведомления перед запуском задания - При вызове любого задания, планировщик будет выводить окно уведомления с описанием задания и возможностью отменить его вручную. Уведомление имеет обратный отсчет, по истечении которого задание запустится автоматически. Окно уведомления задерживает выполнение задания на 10 сек.
  • Уведомлять о заданиях перед завершением сессии Windows - Если в списке планировщика остались какие-либо невыполненные задания (периодические недельные задания в этом случае всегда считаются невыполненными), то при выключении компьютера планировщик напомнит об этом с помощью окна уведомления. Вы можете в течении 15 секунд отказаться от выключения компьютера. Окно уведомления планировщика будет проигнорировано операционной системой, если выключение компьютера было сгенерировано с использованием режима форсирования каким-либо другим приложением.
  • Значения по умолчанию при создании нового задания - значения (тип задания, режим записи, пресет, шаблон имени файла, завершающее действие), которые подставляются в качестве параметров при создании нового задания. Если выбранного по умолчанию пресета по каким-то причинам больше не существует, то вместо этого параметра будет выбрана строка <Не выбран> и при записи будут использованы текущие настройки в "Панели записи".

Использование макросов при задании шаблона:

Поддерживаются 15 типов макросов, позволяющих гибко задать шаблон имени файла для записи. Для облегчения ввода макросов, можно вызвать диалог подсказки, откуда можно вставить макрос в строку путем двойного клика по нужной строчке.

Макрос %channel% вернет "" (пусто) при работе в режимах VHS и S-VHS.
Макрос %tvguide% вернет "" (пусто), если не используется режим ТВ, либо программа телепередач отсутствует или устарела. Максимальная длина строки при обработке этого макроса задается в настройках планировщика. Внимание! Наименование ТВ программы подтягивается из базы ТВ программ по времени запуска, указанному в задании.

Например, задав шаблон в виде:
%mode%-%channel%(%yy%%mm%%dd%-%hh%%nn%) %tvguide%
он сконвертируется в имя файла:
"TV-7ТВ(051215-1913) '220 вольт' (DV"

Расширение имени файла подставится автоматически, в зависимости от типа записи.


Agent

Behold TV - Агент

Агент Behold TV является самостоятельным приложением из пакета программного обеспечения Behold TV и предназначен для:

  • Запуска основного приложения Behold TV с пульта ДУ.
  • Запуска основного приложения Behold TV в назначенное время для выполнения задач встроенного планировщика. При этом, Агент может поднимать систему из спящего (Hibernate) и ждущего режима.
  • Загрузки и обновления баз ТВ Программы формата JTV вручную и в автоматическом режиме.

1. Закладка по настройке загрузки и обновления баз ТВ Программы:

  • Настройка URL - Список адресов URL для загрузки архива базы ТВ-программы из сети Интернет. Первый URL в списке является текущим и будет использоваться Агентом для загрузки. Для того, чтобы добавить URL в список, нужно ввести текст и подтвердить клавишей Enter. Для того, чтобы удалить URL, нужно удалить содержимое строки и подтвердить клавишей Enter. Внимание! Агент поддерживает только прямые ссылки на архивы формата RAR и ZIP. Если в качестве URL введена ссылка без файла или ссылка на html страницу, то при ручном выполнении команды "Обновить", агент откроет Internet браузер по указанной ссылке и закончит свою работу, предоставив возможность для ручной закачки баз ТВ-программ.
    Обычно составители баз ТВ-программ формата JTV обновляют архивы баз на своем Интернет сайте один раз в неделю. Некоторые составители баз каждую неделю меняют имя файла ссылки. Для автоматизации процесса загрузки файлов по некоторым таким ссылкам, Агент может использовать макроподстановки в адресе URL. Внимание! В каждом URL допускается использование не более одной макроподстановки. Текущая версия Агента поддерживает 3 типа макроподстановок:
    • Макроподстановка Date <Допустимый формат даты>, где в качестве допустимого формата даты могут использоваться литеры d, dd, m, mm, yy, yyyy. Литера d подставляет день без ведущего нуля, литеры d d подставляют день с ведущим нулем, литера m подставляет месяц без ведущего нуля, литеры mm подставляют месяц с ведущим нулем, литеры yy подставляют двухзначный год, литеры yyyy подставляют четырехзначный год. Максимальная длина - 16 символов. Например, ссылка .../bases/moscow9102005.zip может каждую неделю изменяться и менять дату в имени файла. Для того, чтобы автоматизировать процесс загрузки такой ссылки, нужно в качестве URL указать .../bases/moscow<dmmyyyy>.zip. В этом случае Агент сам сможет находить и загружать файл по этой ссылке.
    • Макроподстановка Padding [xxx...], где в качестве x подставляется любая буква или цифра. Максимальная длина - 10 символов. Агент будет наращивать данную строку из x символов, слева направо, начиная с пустого места . Например, при ссылке .../jtv[06b3g]5.zip , будут перебраны файлы с именами jtv5.zip, jtv05.zip, jtv065.zip, jtv06b5.zip, jtv06b35.zip, jtv06b3g5.zip.
    • Макроподстановка Replacement {xxx...}, где в качестве x подставляется любая буква или цифра. Максимальная длина - 10 символов. Агент будет перебирать данную строку из x символов, подставляя последовательно каждый символ. Например, при ссылке .../jtv{06b3g}5.zip , будут перебраны файлы с именами jtv05.zip, jtv65.zip, jtvb5.zip, jtv35.zip, jtvg5.zip.
  • Планировщик обновления - Группа для включения и настройки автоматического обновления базы. Внимание! В целях безопасности, а также ввиду экономии интернет-трафика, Агент никогда не будет сам устанавливать подключение к сети Интернет. Агент будет пытаться закачивать файлы только уже при наличии активного соединения.
    • Включить автообновление - включить автоматический режим, когда агент будет проверять, закачивать и распаковывать архив баз ТВ Программы в назначенный период времени.
    • День недели для обновления - Выбрать день недели, в который Агент будет пытаться загрузить обновление.
    • Разрешенный период времени - Выбрать интервал времени для выбранного дня недели, внутри которого Агенту разрешено загружать обновление. В случае, если указать начальное время больше конечного, то Агенту также будет разрешен интервал в течении следующего дня, до указанного конечного времени.
  • Отображать ход загрузки - Выводить окно статуса и прогресса при загрузке файла.
  • Оставлять архивный файл - После распаковки архива базы ТВ-программ не удалять архивный файл.
  • Извлечь без подкаталогов - Распаковать архив баз ТВ-программ без вложенных подкаталогов. Если архив содержит вложенные папки, агент распакует все файлы в корень папки, определенной для баз ТВ-программ, игнорируя иерархию подкаталогов в архиве.
  • Автоповтор (мин) - Интервал повторных проверок, после неудачной попытки соединения и/или загрузки файла. После запуска Агента, в случае, если выбранный день недели и разрешенный интервал времени удовлетворяет текущему времени, а также если со время последнего обновления прошло больше 6 дней и в том случае, если присутствует активное соединение с Интернет, Агент через 1 минуту сделает первую попытку загрузки файла по указанной ссылке.
  • Лог файл - Максимальный размер лог-файла, после достижения которого, лог-файл будет перезаписан заново.

Информация:
Агент использует текущие параметры настройки Интернет-соединения из браузера MS Internet Explorer. В случае, если в системе используется другой браузер по умолчанию, нужно открыть "Панель управления", выбрать иконку "Свойства обозревателя" и на закладке "Подключения" настроить свой тип подключения.

2. Закладка общих настроек:

  • Загружать Агента при старте Windows - Поместить запуск Агента в автозагрузку Windows.
  • Ожидать события планировщика Behold TV для запуска заданий - Использовать Агента, для того чтобы он мог запускать основное приложение Behold TV для выполнения назначенных задач встроенного планировщика. Если система находится в спящем/ждущем режиме, Агент сам поднимет ее перед вызовом приложения Behold TV.
  • Запускать Behold TV по двойному клику иконки в трее - Использовать запуск основного приложения Behold TV при двойном щелчке мыши по иконке Агента в системном трее. В противном случае откроется панель настрок Агента.
  • Ожидать нажатия "Power" пульта ДУ для запуска Behold TV - Использовать Агента, для того чтобы он мог запускать основное приложение Behold TV, путем нажатия на кнопку Power пульта дистанционного управления. Также, в случае использования стороннего пульта ДУ, Агент запустит приложение по нажатию кнопки этого пульта, если данная кнопка определена для включения питания компьютера (см. Настройки).
    • Командная строка для запуска Behold TV с ПДУ - При запуске приложения Behold TV с пульта ДУ, Агент может передать приложению параметры через ключи командной строки. В данной строчке можно указать требуемые ключи. Список допустимых ключей командной строки см. в описании.
  • Выбор языка - Выбрать нужный язык интерфейса для Агента.
  • Приоритет Агента - Задать необходимый приоритет основного процесса Агента.


CommandKey

Ключи командной строки

Для запуска программы в назначенное время можно использовать планировщик Windows, или любой другой планировщик , управляя параметрами запуска из командной строки. Допустимые префиксы ключей "-" и "/"

Ключ | Команда
-m:tv | Включить режим TV
-m:fm | Включить режим FM (для модели с FM)
-m:cp | Включить режим VHS
-m:sv | Включить режим S-VHS
-fs | Переключиться в полноэкранный режим
-ch:xxx | Переключить на xxx канал (нумерация с 1)
-mute | Выключить общий звук (не влияет на запись звука)
-lnmute | Выключить звук линейного входа микшера (не применимо для режима записи)
-vol:xxx | Установить громкость xxx (0-255)
-tr | Запустить программу свернутую в трей (suspend to tray)
-wu | Активизировать программу из трея (wake up)
-r:video | Начать запись видео/аудио
-r:audio | Начать запись только аудио
-r:stillxxx | Начать запись скриншотов с интервалом в xxx секунд
-d:xxx | Длительность записи xxx минут
-fn:"имя" | Задать имя файла при захвате. Если имя не задано, применится таймштамп (обязательно в кавычках )
-nv | Форсировать запись видео без просмотра (только с ключом -r:video)
-ps:"имя.pst" | Указать имя пресета для считывания настроек (обязательно в кавычках )
-exit | После окончания записи выйти из программы
-shut | После окончания записи выйти из программы и выключить компьютер

Примечание:
Ключи -lnmute, -tr, -fs не совместимы с режимом записи, вызванным из командной строки посредством ключа -r:.

Ключ -fn:"имя" может быть указан в виде шаблона с использованием макросов. Подробное описание макросов можно прочитать в описании планировщика.

Пример:
Запустить программу, выбрать 8 канал, запустить запись видео на 25 минут, в файл "tom and jerry.avi", по окончании записи выключить компьютер:

c:\beholdtv\beholdtv.exe -m:tv -ch:8 -r:video -fn:"tom and jerry" -d:25 -shut

Примечание: Выход из программы (-exit), либо выключение (-shut) производится через 3 секунды после останова записи по ключу -d:xxx.


Advice

Советы по видеозаписи

О кодеках...

Microsoft AVI
Большинство AVI видеокодеков, входящих в пакет Microsoft DirectX, предназначены для постобработки готового видео и мало пригодны для работы в режиме реального времени. Большинство этих кодеков не поддерживают YUY2 и RGB24 форматы видео.

Такой широко распространенный кодек как DivX также мало подходит для сжатия эфирного видео на лету. Для его применения желательна предварительная обработка видеоматериала для удаления шума. Высокочастотный шум очень плохо поддается компрессии эти кодеком и общее качество изображения после сжатия при фиксированном битрейте получается неудовлетворительным.

DivX и Microsoft DirectX кодеки могут быть применены для окончательного сжатия видео с помощью таких программ, как, например, Virtual Dub.

Если необходимо получить видео высокого качества, то запись необходимо вести либо без сжатия, либо с небольшим коэффициентом компрессии для уменьшения потока данных. Лучше всего для этих целей подходит lossless кодек Huffyuv 2.2.0, который основан на алгоритме Хаффмана, сжимает без потерь и обеспечивает идеальное качество изображения. Кодек Huffyuv сжимает с коэффициентом всего 2-3, вследствие чего формируется поток данных объёмом 10-15 МБ/сек. Т.к. далеко не каждый жесткий диск в состоянии справиться с записью подобного объёма информации без выпадения кадров, то для сжатия без потерь рекомендуется использование жестких дисков с частотой вращения шпинделя не менее 7200RPM или использовать IDE RAID массив.

Если жесткий диск не позволяет записывать поток с высокой скоростью, то можно попробовать использовать Motion JPEG кодеки - Morgan MJPEG, PICVideo MJPEG, либо MainConcept MJPEG. С помощью этих кодеков можно добиться высокого качества изображения при небольшом потоке данных (3-8 МБ/с). В настройках PICVideo MJPEG кодека это соответствует качеству 17-19. Для Morgan MJPEG кодека - 85-95. Однако эти кодеки сжимают с потерями, так как основаны на алгоритме внутрикадрового сжатия JPEG.

Из кодеков, дающих максимальное сжатие при максимальном качестве, можно посоветовать XviD. Последний кодек требует огромных вычислительных ресурсов, но качество изображения получается высоким.

По мере возможности, старайтесь не делать захват в AVI, со сжатием аудио на лету. Это грозит рассинхронизацией видео и аудио потоков, либо при использовании некоторых аудиокодеков, может вызвать внезапную остановку записи. Используйте аппаратный формат аудио - PCM.

Microsoft WMF
Для высококачественной записи видео и аудио можно использовать Windows Media Format (WMF). Windows Media Format имеет высокое качество изображения и звука при большой степени сжатия контента. Данный формат укладывает видео и аудио потоки в контейнер ASF, который является продолжением развития AVI и имеет дополнительные функции по синхронизации потоков. Файл в контейнере ASF, в котором видео поток сжат кодеком Windows Media Video обычно имеет расширение .wmv. В случае записи и сжатия только одного аудио потока кодеком Windows Media Audio, файл обычно имеет расширение .wma. Для кодирования файлов в Windows Media Format, используя ПО Behold TV требуется OS Windows XP SP2, либо установленный апдейт Microsoft Windows Media Format Runtime 9.0/9.5/11. Данный апдейт можно установить через Windows Update, либо взять с CD диска ТВ тюнера Beholder. Если апдейт не установлен, запись в форматы WMV/WMA/ASF будет недоступна. Windows XP SP2 уже имеет в поставке Windows Media Format Runtime 9.0. Windows Vista изначально поставляется с Windows Media Format Runtime 11.

О видео и аудио...

Запись видео совместно со звуком имеет ряд особенностей. Существуют несколько моментов, которые следует помнить. В захвате видео и аудиоряда с помощью ТВ тюнеров, как правило, всегда принимают участие два независимых устройства - устройство оцифровки видео (собственно, сама плата ТВ тюнера) и устройство оцифровки звука (звуковая плата компьютера). Эти устройства работают на опорной частоте своих собственных кварцевых генераторов, каждый из которых может иметь некоторую погрешность. Вследствие этого при оцифровке данных происходит рассинхронизация по времени видео и аудио потоков, что в конечном итоге приводит к отставанию или опережению звука относительно изображения в захваченном файле.
Однако, микросхема Philips SAA7134 а также SAA7135 , помимо видеодекодера, содержит встроенный, независимый от звуковой платы компьютера аудиодекодер и умеет аппаратно связывать аудио и видео потоки, благодаря чему программа Behold TV может гарантированно оцифровывать звук синхронно с видеорядом. Звуковая плата компьютера в данном режиме не используется. Если ваш тюнер построен на чипсете Philips SAA7134 или SAA7135, всегда используйте эту уникальную возможность.
Правда, стоит отметить, что аудиодекодер чипсета SAA7134 оцифровывает звук только с частотой дискретизации 32 кГц. Аудиодекодер чипсета SAA7135 может оцифровывать звук с частотой 32 кГц и 48кГц (а также частотой 44.1 кГц, но только для источника, подключенного к аналоговому входу чипсета).

О Windows...

Вследствие лучшего механизма кэширования и буферизации, а также более грамотного управления приоритетами, запись и работу с видео предпочтительнее проводить на компьютере с установленной операционной системой Windows XP(2000) нежели Windows98(ME). Благодаря поддержке файловой системой NTFS файлов размером более 4 Гб под Windows XP(2000) можно осуществлять продолжительную полноформатную запись видео с небольшим сжатием, а также долговременную работу функции "Таймшифт". Файловая система FAT32, с которой работают операционные системы Windows98(ME), не поддерживает длину файла больше 4 Гб.


Faq

Вопросы и ответы (FAQ)

Просмотр

Вопрос: При запуске программы я вижу черное окно - звук есть, но изображения нет.
Ответ: Ваша видеокарта (драйвера) не поддерживают оверлей в заданном разрешении и битности десктопа. Попробуйте выставить десктоп Windows в 16 бит. Если это не помогает, попробуйте изменить в настройках программы режим вывода изображения при просмотре (Оверлейная/Первичная поверхность), а также изменить размер видеопотока. При выборе оверлейной поверхности под Windows XP попробуйте включить/выключить режим Video Mixing Renderer (VMR). Существует еще одна причина "черного экрана". На многих материнских платах по умолчанию установлено неверное значение PCI Bus Latency в BIOS. В настройках «Видео» тюнера в параметрах PCI DMA контроллера вы можете изменить это значение и тем самым добиться нормальной работы PCI видеодекодера SAA713x. Рекомендуемое значение PCI Latency 16-64. Также, серверные версии операционных систем (Win2000 Server, Win2003 Server) в целях оптимизации производительности по умолчанию полностью или частично отключают аппаратное ускорение видеоадаптеров. Это также приводит к "чёрному экрану" или искажению цветопередачи при работе в разных режимах отображения видео. Зайдите в меню "Диагностика" ("Troubleshooting") дополнительных настроек видеоадаптера и установите аппаратное ускорение на максимум.

Вопрос: При попытке включения режима удвоения частоты кадров, а так же при перекрытии видеоокна окнами других приложений, программа замирает и сильно подтормаживает.
Ответ: Вероятно у вас включен режим Clone и вывод оверлея на телевизор в настройках видеоадаптера. Некоторые драйвера nVidia вызывают данную проблему. Отключите режим Clone, либо установите другой драйвер для видеоадаптера nVidia.

Вопрос: При просмотре телепередач на экране наблюдаются чередующиеся вертикальные полосы! Что делать?
Ответ: Вертикальные полосы, которые возникают на изображении тюнера, могут появляться по двум причинам:
Первая причина – из-за некорректно установленного в BIOS материнской платы параметра PCI Latency Timer. В этом случае помехи на экране выглядят в виде зелёных или малиновых вертикальных полос, заполняющих 4/5 площади экрана. Полосы полностью устраняются подбором значения PCI Latency Timer непосредственно в настройках "Видео" программы Behold TV.
Вторая причина появления помех – наводки на радиоблок тюнера, возникающие при работе шины PCI в момент передачи пакетов данных. Сама помеха формируется непосредственно на входе ВЧ-блока тюнера и не зависит ни от качества блока питания, ни от каких-либо установок в BIOS материнской платы. Наводки от работы шины PCI становятся заметны на программах в низкочастотном диапазоне TV (49-200 МГц) при ослаблении сигнала относительно нормального уровня на 15-20 дБ. На телевизорах таких полос не бывает потому, что на них нет самого источника помех – шины PCI. Единственный способ борьбы с этим явлением – приведение уровня телевизионного сигнала сигнала к нормальному. Для этого:
1) Обеспечьте надёжные и хорошо согласованные контакты во всех соединениях телевизионного кабеля.
2) Минимизируйте количество разветвлений (крабов) кабеля. Каждый краб делит мощность сигнала между всеми подключёнными к нему устройствами. Используйте только качественные делители (крабы).
3) Используйте качественный телевизионный кабель. Он должен иметь волновое сопротивление 75 Ом, не должен быть слишком тонким. Необходимо, чтобы он имел надёжное экранирование, в идеале – двойное, с проволочной сеткой и фольгой. Не следует соединять друг с другом несколько кусков кабеля, – в каждом стыке происходят потери и отражения сигнала. Обеспечьте минимально возможное количество соединений (переходников).
4) Установите усилитель сигнала. Усилитель не следует располагать рядом с системным блоком компьютера или с другими электронными устройствами.
Для более точного определения причины возникновения полос, попробуйте подать сигнал на низкочастотный видеовход с внешнего источника сигнала, например – с видеомагнитофона. Если полосы не исчезли, то причина в неправильном значении PCI Latency Timer. При отсутствии полос – проблема в низком уровне сигнала ТВ-эфира.

Вопрос: При обращении к диску возникают помехи на экране в виде множества тонких белых горизонтальных черточек.
Ответ: Такие помехи проявляются при использовании некоторых SATA- и RAID-контроллеров, и, к сожалению, иногда не устранимы. Эта проблема обусловлена тем, что SATA контроллер передаёт данные по шине большими пакетами, не предоставляя времени для работы другим PCI-устройствам. Это вызывает переполнение буфера FIFO чипсета SAA713x, что приводит к пропуску данных, записываемых в буфер видеокадра. Количество помех можно уменьшить или избавиться от них вовсе, установив в настройках "Видео" тюнера параметр Burst length = 64 или 32 Dwords или подобрав другое значение Latency timer. Попробуйте поменять настройки, касающиеся шины PCI, SATA и RAID-контроллеров в системном BIOS или в BIOS контроллера. Также проверьте, чтобы тюнер и SATA (RAID) контроллер не разделяли одно прерывание.

Вопрос: По краям телевизионного изображения виден мусор в виде тонких полос.
Ответ: Вся телевизионная техника ориентируется на тот факт, что при просмотре изображения на телевизоре около 10% картинки с краёв обрезается телевизором (находится за пределами видимой области кадра). Поэтому в первых и последних строках изображения часто кодируется дополнительная служебная информация, которая выглядит как мусор. В телевизионном стандарте Betacam для маркеров используется первая строка и два первых пиксела всех остальных строк – левый край изображения. Существует ряд других промышленных стандартов, которые, так или иначе, используют края изображения для кодирования маркеров. При помощи кнопок "+" и "-" на дополнительной клавиатуре отмасштабируйте изображение так, чтобы скрыть эти края, либо используйте плагин видеообработки "Заливка бордюров".

Вопрос: При просмотре изображение показывается как бы рывками, что, например, можно заметить при перемещениях бегущей строки.
Ответ: Телевизионное изображение на экране монитора обновляется с частотой 25 кадр/сек или (при включении удвоения частоты кадров в программе) 50 кадр/сек. Экран монитора обновляется с частотой, установленной для десктопа и поддерживаемой вашей видеокартой и монитором. Когда частота обновления монитора не совпадает с частотой телевизионных кадров, возникают так называемые биения, которые и видны, как подёргивания бегущей строки. Теоретически, биения будут возникать при любой частоте обновления кадров монитора, однако, при 75Гц частота биений достаточно высока, что снижает их субъективное восприятие как дёрганье. Также при выключенном удвоении частоты кадров на глаз весьма заметны 25 герц. На телевизоре этого не видно, поскольку изображение реально выводится с частотой 50 полей в секунду.

Вопрос: Может ли тюнер выводить изображение с более высоким разрешением, например, 1024х768 или 1280х1024?
Ответ: В данном случае необходимо не путать некоторые понятия и чётко себе представлять, что качество телевизионного изображения соответствует максимальному разрешению 720х576 (в системе PAL/SECAM) или 720х480 (NTSC). Именно в этих разрешениях работают практически все известные модели телевизионных тюнеров. Оцифровка тюнером изображения с большим разрешением по вертикали невозможна из-за ограничения, накладываемого количеством физических строк в телевизионном кадре (576 – PAL/SECAM, 480 - NTSC). Использование большего разрешения при оцифровке по горизонтали нерационально, т.к. это не приводит к повышению качества изображения. В полноэкранном режиме изображение растягиванием до размеров полного экрана аппаратным ускорителем графической карты.

Вопрос: При регулировке громкости уровень звука не изменяется и функция выключения звука (Mute) не работает, хотя индикатор изменения громкости и значёк Mute отображаются на панели управления.
Ответ: Проверьте, чтобы тюнер был подключен к аудиоплате в соответствии со схемой его подключения: внутренний или внешний аудиовыход тюнера должен быть подключен соответственно к внутреннему или внешнему входу аудиоплаты. Непосредственное подключение акустической системы к аудиовыходу тюнера является не правильным. Также, проконтролируйте, чтобы в настройках «Аудио» тюнера в качестве микшера и линии управления звуком были выбраны, соответственно, аудиоплата и канал аудиоплаты, к которому подключен внутренний или внешний аудиовыход тюнера.

Вопрос: Периодически, раз в полчаса-час, пропадает звук при просмотре ТВ-программ!
Ответ: Если у Вас в фоне запущены какие-либо утилиты, то попробуйте выгрузить их по одной. Такие программы, как Microsoft NetMeeting, Messenger, Norton Antivirus и некоторые другие, работая в фоне, могут блокировать каналы звуковой карты.

Запись

Вопрос: Я пытаюсь захватывать в AVI со звуком. Захват идет без ошибок, но при проигрывании полученного видеофайла нет звука.
Ответ: Здесь могут быть следующие причины:
1) Убедитесь, что в настройках записи аудио в качестве микшера и активной линии записи выбран тот канал звуковой платы, к которому подключен внутренний или внешний аудиовыход тюнера.
2) Если вы правильно выбрали активную линию записи, но при захвате звука нет по-прежнему, то возможно, что драйверы для вашей звуковой карты не обеспечивают корректную поддержку переключения источников звука через WDM. К сожалению, такое встречается. Например, драйвера для карты Creative SB PCI 128 под Windows 2000(XP), устанавливаемые самой Windows, работают корректно. В то же время драйверы, установленные с сайта Creative под Win2000(XP), не позволяют переключить источник записи даже через системный микшер.
3) Некоторые проигрыватели, например, LightAlloy не всегда корректно воспроизводят записанный файл. Попробуйте воспроизвести запись при помощи системного MediaPlayer.
4) Если у вас не подключён аудио-кабель, то необходимо убедиться, что в выбранном вами для записи пресете установлена галочка "Запись звука чипсетом через PCI".

Вопрос: Не получается сделать захват видео со звуком. При попытке начать запись, выдается сообщение об ошибке "Cannot start graph". Видео без звука пишется без проблем.
Ответ: Некоторые устройства, например голосовые модемы, добавляют в категорию устройств аудио захвата свои устройства. Зайдите в "Панель управления" Windows, откройте "Мультимедиа(Звуки и аудио устройства)" и в закладке "Аудио" в списках "Используемое по умолчанию устройство" как для записи, так и для воспроизведения выберите вашу звуковую плату. Включите флажок "Использовать только устройства по умолчанию". Перезагрузите Windows. Откройте панель записи Behold TV и на закладке "Настройка записи аудио" выбирите в списках вашу звуковую карту.

Вопрос: При записи в формате AVI звук сильно отстаёт от видео.
Ответ: Рассинхронизация аудио и видео потоков при записи может происходить в результате множества причин. Попробуйте установить для звука формат PCM. Некоторые аудиокарты, такие как Sound Blaster Live!/Audigy обеспечивают синхронность только при частоте дискретизации 48000 Гц. Подбирайте видеокодек и его параметры так, чтобы загрузка процессора была не выше 80 %. Также, не рекомендуется ставить в настройках наивысший приоритет. Попробуйте разные значения параметров "Чередование (Interleaving)", "Главный поток AVI". Если ваш тюнер собран на чипсете Philips SAA7134/35, то используйте при захвате встроенный в него аудио АЦП .

Вопрос: При попытке записи в видео, система "падает".
Ответ: Возможно несколько проблем:
1) Системная - Для вашей материнской платы не установлен пакет драйверов от производителя, либо в вашей системе несколько устройств (включая тюнер и звуковую карту) делят одно прерывание IRQ.
2) Программная - конфликт драйверов или DirectShow фильтров.

Вопрос: При видеозахвате MPEG кодеком InterVideo и последующем воспроизведении, либо при использовании функции Таймшифт, происходит плавающее искажение и заикание звука.
Ответ: Установлено, что данная проблема проявляется на материнских платах, построенных на чипсете nVidia nForce2, при включенной в BIOS опции "FSB Spread Spectrum". Отключение данной опции устраняет проблему с кодеком InterVideo. На большинстве материнских плат данная опция находится в разделе BIOS "Advanced Chipset Features".

Вопрос: При остановке записи система виснет.
Ответ: Если Вы пишите в формате AVI с использованием кодека XviD, то необходимо зайти в настройки кодека и отключить Debug Window. Именно это приводит к зависаниям при остановке записи.

Вопрос: В лог файл при записи видео кодеком divx пишется "Video codec: DivX Pro 5.0.5" независимо от реального установленного в системе.
Ответ: Приложение выводит то название кодека, которое ему сообщает DirectShow. DirectShow, в свою очередь, хранит название только самой первой версии установленного в систему кодека, причём любого. При обновлении версии кодека его название не изменяется. Это недоработка в самом DirectShow. Чтобы после обновления версии кодека (в данном случае DivX) его имя в системе поменялось, необходимо найти и вручную удалить ветку реестра:
HKEY_CURRENT_USER\Software\Microsoft\ActiveMovie\devenum\{33D9A760-90C8-11D0-BD43-00A0C911CE86}\divx
После удаления ветки реестра она появится снова, но с уже корректным именем кодека, а в самом приложении необходимо будет перевыбрать DivX кодек, чтобы его новое имя сохранилось в настройках.

Вопрос: Запись останавливается по достижению записанным файлом размера 4Гб.
Ответ: У вас установлена файловая система FAT32, которая не поддерживает размер файла больше 4 гигабайт. Для записи больших файлов вам необходимо конвертировать файловую систему в NTFS. Также при записи в формате MPEG-2, WMV или ASF вы можете установить автоматическое разбиение записанного файла на сегменты заданного размера.

Вопрос: При записи звука аудиокодеком ACM Lame MP3 в формате 48000 Hz, 320 kbps CBR, Stereo, в полученном файле нет звука.
Ответ: В комплекте Windows XP поставляется DirectShow декодер "Fraunhofer IIS MPEG Layer-3 DirectShow Decoder" старой версии 1.5, который не умеет декодировать VBR MP3, а также не умеет декодировать некоторые форматы MP3, записанные не Fraunhofer кодировщиками. Для решения проблемы необходимо обновить данный декодер (файл l3codecx.ax) до версии 1.9.0.311. После этого ранее записанные файлы будут воспроизводиться корректно.

Вопрос: Записываю видео способом "Microsoft WMV". Использую кодек Windows Media Video 9. При воспроизведении записанного файла изображение получается с испорченными, искаженными цветами, и выглядит а-ля фреска.
Ответ: В вашей системе установлен старый декодер Windows Media Video. Необходимо обновить с сайта Microsoft обновленный пакет декодеров Windows Media или установить Windows Media Player 10, либо использовать кодек Windows Media Video V8.

Вопрос: Записываю видео способом "Microsoft WMV". Использую кодек Windows Media Video 9. При воспроизведении записанного файла, при попытке выполнить быструю перемотку, позиционирование, либо переключиться в оконный/полноэкранный режим, изображение застывает. Помогает только повторное открытие файла.
Ответ: Установлено, что на видеокартах ATI Radeon, такое поведение вызвано активной опцией "Ускорение WMV" в настройках драйвера видеокарты, на некоторых версиях драйверов ATI Catalyst 5.xx. Отключение опции "Ускорение WMV" помогало решить данную проблему.

Вопрос: При записи в AVI появляется очень много пропущенных кадров, хотя загрузка процессора не достигает критической.
Ответ: Это происходит на двухъядерных процессорах, преимущественно AMD Athlon64x2, из-за рассинхронизации (drift) счетчиков ядер. Программы и драйверы, использующие системный вызов QueryPerformanceCounter будут получать разные значения счетчиков из-за чего возникают проблемы. Продиагностировать систему на рассинхронизацию счетчиков можно с помощью утилиты ICEAffinityTest.exe. Данная проблема официально описана Microsoft. Для решения проблемы необходимо добавить ключ /usepmtimer в файл boot.ini, в строку с выбором операционной системы и перезагрузить систему. Например:
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Windows XP Professional" /noexecute=optin /fastdetect /usepmtimer

Вопрос: Записываю видео аппаратным энкодером SAA6752HS на ТВ тюнере Behold TV M6. При воспроизведении файла иногда видны дефекты в виде случайных блочных полос, а также сильные рывки изображения. При попытке перекодировать данный файл различными программами, они выдают ошибку типа "Incompleted Frame at...". Что мне делать, неужели барахлит аппаратный энкодер?
Ответ: Данные ошибки вызваны не дефектом энкодера, а последующей порчей MPEG2 потока, передаваемого по шине PCI а также потерей фрагментов потока. В порче потока виновато одно из PCI устройств (обычно IDE и SATA контроллеры), надолго удерживающее арбитр шины PCI, в следствии чего FiFo буфер чипсета переполняется и в семплах потока происходит искажение данных. Для контроля DMA потока достаточно включить лог-файл при записи. После окончания записи нужно открыть лог-файл и в разделе * Record task statistics * посмотреть статистику "Total corrupted MPEG DMA samples" и "Total lost MPEG DMA samples". Если система работает исправно, там должны быть нули. Если одно из значений ненулевое (особенно corrupted), нужно переставить ТВ тюнер в другой слот, либо попробовать настроить параметры PCI DMA контроллера в настройках ПО Behold TV. Уменьшая Burst length, FiFo threshold, либо увеличивая Latency timer, нужно добиться того, чтобы в лог-файле показатели ошибок MPEG DMA были нулевыми.

Таймшифт

Вопрос: Не запускается режим Таймшифт.
Ответ: Таймшифт в программе Behold TV работает только при наличии установленных в системе InterVideo MPEG кодеков. Кодеки устанавливаются в систему вместе с программой InterVideo WinDVD Creator из комплекта поставки тюнера. Проверить наличие установленных в системе MPEG-кодеков можно в меню «Таймшифт» настроек программы Behold TV в группе «Статус готовности режима Таймшифт».
Также, Таймшифт может не запускаться из-за конфликтов разных версий кодеков InterVideo, входящих, например, в комплекты разного рода кодек-паков. Статус готовности не в состоянии отследить такие конфликты. В этом случае помогает деинсталляция кодек-паков и переустановка программы InterVideo WinDVD Creator.

Вопрос: При запуске режима Таймшифт слышно два аудиоканала звука, смещённых один относительно другого по времени.
Ответ: При работе Таймшифт приложение тюнера отключает основной канал работы с аудиоплатой и выводит звук из записываемого файла. Если при работе Таймшифт прослушиваются два аудиоканала, смещённые один относительно другого по времени, то это означает, что в настройках «Аудио» тюнера неверно выбран «Микшер воспроизведения» или «Линия управления звуком», с которыми работает тюнер.

Вопрос: Пропадает звук при включении режима Таймшифт.
Ответ: Эта проблема присутствует при использовании звуковых плат Creative Labs Audigy, Audigy II и SB16. При работе Таймшифт приложение тюнера отключает основной канал работы с аудиоплатой (чтобы не было слышно, что идёт в реальном времени), и выводит звук из записываемого файла. Драйвера Creative Labs содержат ошибку, в результате которой при попытке отключить канал на воспроизведение, отключается также и запись с этого канала. Никакие другие, известные нам звуковые платы и аудиокодеки, такой ошибки не содержат. Компания Creative Labs знает об этой ошибке, но пока её не устранила. В новых версиях ПО мы обошли эту ошибку, однако, иногда она всё же возникает и простого решения не имеет.

Пульт ДУ

Вопрос: Тюнер не реагирует на команды пульта ДУ.
Ответ: Проверьте надёжность крепления ИК-датчика в гнезде на плате тюнера. Проверьте, не сели ли и правильно ли установлены элементы питания внутри корпуса пульта ДУ. Косвенно проверить работоспособность самого пульта ДУ можно, посветив им в объектив цифровой фото- или видеокамеры. Из-за инфракрасного смещения матрицы камеры. Также, проверьте, не отключено ли использование пульта ДУ в настройках тюнера?

Вопрос: Пульт ДУ не работает, постоянно моргает индикатор пульта ДУ в программе, как будто нажата кнопка "0".
Ответ: Постоянное нажатие кнопки "0" пульта ДУ детектируется в том случае, если неисправна микросхема ИК-декодера или цепь сброса микросхемы. Иногда неисправность имеет плавающий характер, в результате чего декодер то работает, то нет. В любом случае, необходимо обменять тюнер по гарантии или сдать на ремонт в сервис-центр.
Также, постоянное нажатие кнопки “0” может проявляться при наличии конфликта прерываний платы тюнера с другими PCI устройствами в системе. В этом случае необходимо переставить плату тюнера в другой PCI слот и проследить за тем, чтобы выбранному слоту было присвоено отдельное прерывание.

Вопрос: Некорректная работа дистанционного управления.
Ответ: Ситуации делятся на две категории:
1) ИК-датчик ошибочно ловит и распознаёт в качестве повтора сигналы от источников ИК-помех – в первую очередь от электролюминесцентных ламп.
2) ИК-датчик содержит в себе высокочувствительный фототранзистор. В результате, электрические наводки на шнур датчика или на сам датчик также вызывают ложные срабатывания в случае, если датчик крепится к корпусу ПК или к другим металлическим поверхностям.

По характеру воздействия помех также есть два механизма:
1) Помеха ошибочно распознаётся, как код повтора (более редкий случай). В этом случае наблюдается периодическое случайное срабатывание последней нажатой кнопки.
2) Помеха искажает код кнопки, в результате чего нажатая кнопка не определяется. Следом за кодом кнопки идёт код повтора, который воспринимается декодером и вызывает срабатывание предыдущей кнопки, оставшейся в буфере декодера.
На данный момент рекомендации следующие. Не закрепляйте датчик на корпусе ПК. Попробуйте закрепить датчик на некотором расстоянии от ПК на непроводящей поверхности. Если у вас есть электролюминесцентные осветительные приборы, проверьте их исправность, лампы замените на свежие и попытайтесь изолировать ИК-датчик от их света.
В новых моделях тюнеров и в последних партиях моделей 401 и 403FM полностью переделана логика работы микросхемы ИК-декодера, в результате чего ложные срабатывания от помех или ошибочное распознавание инфракрасного сигнала практически полностью исключены.

Прочее

Вопрос: В комплекте к тюнеру идёт программа WinDVD Creator, но серийный номер к ней не подходит.
Ответ: При вводе серийного номера будьте внимательны при наборе букв "O", "I", "G", "S" и похожих на них по начертанию цифр "0", "1", "6", "5".

Вопрос: При включении режима телетекста, я вижу вместо шрифта какую-то псевдографику и каракули.
Ответ: Это ошибка регистрации шрифтов в инсталляторе DX8. В папке \WSTRus, вы найдете файл wst_w9x.reg (для Windows 98-ME) и wst_w2k.reg (для Windows 2000). Запустите соответствующий файл и перезагрузите Windows.
Также, некорректное отображение страниц телетекста возможно по причине того, что встроенный в Microsoft DirectX программный декодер телетекста крайне чувствителен к качеству принимаемого сигнала.

Вопрос: После обновления Windows выскакивает сообщение: "WDM device "SAA7134 TV card" – is not Philips SAA713x card".
Ответ: Подобное сообщение появляется после того, как обновлённые версии WinXP по умолчанию устанавливают для тюнера собственные драйверы (автоматически скачивая с сайта MS), несовместимые с тюнерамии Behold TV. Чтобы переустановить драйверы на те, что идут в комплекте с тюнером (или загруженные с нашего сайта), запустите инсталлятор из комплекта поставки драйверов (файл Install.exe), удалите все предыдущие инсталляции чипсета Philips SAA713x и установите WDM драйвер Behold TV заново.

Вопрос: При работе тюнера система зависает.
Ответ: Основной причина такого поведения системы являются PCI-конфликты. Вот основные источники таких конфликтов.

1) Неполная или некорректная поддержка спецификаций шины аппаратной частью устройства или PCI-контроллером.
Как правило, это проявляется в том, что:
a) Устройство и материнская плата несовместимы друг с другом, они по разному трактуют работу шины.
b) Устройство или контроллер шины нестабильно работают или не работают при некоторых установках шины.
c) Нестабильно работает система в целом, поскольку устройства требуют взаимно исключающих установок.
Очень часто эти проблемы устраняются определёнными установками BIOS, иногда не устраняются никак. К этому же случаю, пожалуй, можно отнести некорректное программирование PCI-контроллера BIOS материнской платы, некорректную инициализацию PCI-устройств системой и неправильная установка устройством своего конфигурационного пространства. Дело в том, что инициализация PCI-устройства также представляет собой непростую процедуру, связанную со считыванием конфигурационного пространства устройства и настройкой контроллера шины в соответствии со считанными данными.

2) Аппаратные проблемы, связанные с арбитражем шины. Дело в том, что шина используется совместно всеми устройствами, подключёнными к ней. Если двум или более устройствам одновременно потребовался обмен данными с системой, то в процессе арбитража определяется, которое из устройств получит доступ к шине, а какое обязано будет ждать. На этом этапе существует множество подводных камней, связанных с тем, что одни устройства могут ждать неопределённо долго, для других же время является критичным фактором. Типичным случаем такой проблемы является несовместимость (иногда неустранимая) с некоторыми SATA, SCSI или RAID-контроллерами. Другим возможным случаем является просто некорректная отработка процедуры арбитража одним из устройств или контроллером шины.

3) Проблемы связанные с распределением прерываний. Теоретически, спецификации шины PCI позволяют использовать одно прерывание несколькими устройствами. На практике же это сопряжено с некоторыми сложностями. Механизм прерываний в шине PCI двухуровневый. На первом уровне задействована только шина (аппаратная часть). На втором уровне путём считывания и программирования PCI-регистров из нескольких устройств выделяется одно или более, действительно активизировавшие прерывание. В данном случае могут сказаться ошибки в драйверах любого из двух устройств, разделяющих одно прерывание. В случае, если прерывания устройствами не разделяются, эти ошибки никак себя не проявят. К сожалению, в данной ситуации недостаточно того, чтобы без ошибок был написан драйвер нужного вам устройства. Необходимо, чтобы ошибок не содержали драйвера всех устройств, разделяющих прерывание.

4) Косвенные проблемы, напрямую не связанные со спецификациями PCI. В первую очередь это взаимное влияние устройств по питанию. Дело в том, что любое цифровое устройство (к которым, безусловно, относятся PCI-устройства) является активным источником помех по цепям питания и земли. Также оно само может быть чувствительно к помехам при достижении ими определённого порогового уровня. Другая проблема, также связанная с питанием, заключается в изменении уровня нагрузки при работе устройства и, как следствие, проседание или "плавание" напряжения на этом или соседнем устройстве. Также система может оказаться просто неспособной обеспечить необходимую нагрузку. К этому же пункту относится и изменение нагрузочной способности сигнальных линий шины, изменение крутизны фронтов и временных диаграмм сигналов при подключении дополнительных устройств.
Не стоит приуменьшать вероятность любой из описанных ситуаций. В нашей практике встречались все случаи. Всё сказанное показывает глубину сложности диагностики и устранения подобных конфликтов. При возникновении конфликта мы можем привести только наиболее общие рекомендации, как то:

1) Переставьте устройство в другой слот.
2) Попробуйте разнести прерывания устройств в BIOS Setup компьютера.
3) Попробуйте изменить настройки BIOS, касающиеся шины PCI.
4) Попробуйте временно запретить, а ещё лучше удалить по очереди из системы устройства, чтобы обнаружить конфликтующие.
5) Обеспечьте качественное питание системы.
6) В настройках ПО, в закладке "Видео" измените параметры PCI DMA контроллера.

Что касается наших устройств. Безусловно, мы не перекладываем всю ответственность на других. Мы делаем всё, от нас зависящее, чтобы предупредить возможные конфликты. Тем не менее, есть ряд факторов, которые от нас никак не зависят:
1) Чипсеты разрабатываем не мы. Несмотря на то, что Philips Semiconductor производит одни из самых стабильно работающих чипсетов, аппаратные проблемы всё ещё встречаются.
2) При возникновении конфликта возникают объективные сложности в выяснении причин и "виновника".

Вопрос: Чипсет и другие элементы платы тюнера сильно греются.
Ответ: Это совершенно нормально. Болевой порог теплового восприятия довольно низкий – 56°. В соответствии со спецификациями допустима рабочая температура чипсета и стабилизаторов до 70-80°, которая воспринимается как обжигающая. Кроме того, тепловыделение обусловлено конструкцией микросхемы чипсета и от нас, как разработчиков тюнера, никак не зависит.

Вопрос: База данных телевизионных программ давно не обновлялась.
Ответ: Компания Beholder не занимаемся самостоятельно ни подготовкой, ни распространением баз ТВ-программ. В программе Behold TV осуществляется только поддержка баз ТВ-программ в формате JTV, которые можно вручную или автоматически скачать с разных ресурсов в Интернет. Некоторые ресурсы по разным причинам могут не работать или обновлять базы нерегулярно. Все доступные ссылки на дополнительные ресурсы в сети, с которых можно скачивать обновления, можно найти в выпадающем списке «Настройка URL» в опциях программы Behold TV agent. Дополнительные ссылки можно внести в программу самостоятельно.


Links

Контактная информация

Официальный сайт:
http://tuner.beholder.ru/

Страница поддержки:
http://tuner.beholder.ru/support/

Форум:
http://www.beholder.ru/bb/

E-mail:
 support@beholder.ru